My Glowforge died in the first week of having it

I have sent a ticket but I want to elaborate here since support can only be reached via leaving a message.

When I first received my Glowforge I would have to turn the off/on button a few times before it would actually turn on. I did not think much about that since it did turn on and I was able to make my first cut for the Good Measure I then created some miniature cutting boards (the same day) then left it alone for a few days until I received my pre-cut plexiglass to create my window vent.

A couple days later I received my plexiglass and was able to make my window vent today. I just needed to make a simple straight line cut and a 4 inch hole on the .50" plexiglass. I am not sure if this happened with my good measure cuts or the miniature cutting boards as I did not need the cuts to be precise on the material as I did for these cuts but they were off by about a 1/2". I had to cut a single cut multiple times just to even get close to the measurements I needed.

On my last cut my machine completely shut down and the app showed an “Interlock Open” alert. I then started to research what that meant from the forums on this site and saw that the staple pin was properly in place so that was not the issue but the alert still remained.

After that I attempted to test cut but upon turning on the machine, this time, only by unplugging and plugging the power supply on the back of the machine would turn it on. Once turned on it would start to power up and then completely cut off. I tried this several times and now it will not come on at all. Now If I attempt to turn on the machine I only hear a faint click.

I have checked the power that is plugged in directly to my wall with a 3 prong adapter. I did read before I got the machine that it should only be plugged into the wall so I did not add it to my surge protector that is connected to my other plug in that outlet. The outlet only has my cricut maker, cricut joy and a small desk fan plugged in which is not turned on most of the time. Only when in use and I was only using the desktop fan when the laser printer was in use.

-I checked the outlet to make sure that it was not being overloaded by removing the other items that were on the surge protector in the adjoining plug in that outlet.

-All other items in use in that outlet were still in working order.

-I checked the actual plug and the 3 prong adapter with other appliances , in the same plug I used for the Glowforge, and they worked fine.

-there is adequate power going to that plug as it is on a 20W amp.

Is there any other checks I need to do? This is very disheartening as I got the PRO model thinking I was getting the best and the machine did not even last a week or a decent amount of cuts. I am losing money while this sits in my studio room not working not to speak of all the other items I purchased that I needed to use with this machine. Very costly for it not to be working. In my line of business as with most time is money.

I will need to cancel my Premium subscription, for now, as I am unable to use this machine. Even more money I spent with the anticipation of getting right to business with my GF machine.

Thank you and I await your swift response!

1 Like

When you send email and post here it opens another ticket which will slow the response. I know it is tough to get that one in a thousand that has a problem as it is 100% of the ones you purchased. If they replace several machines and they all have the same problem, then it is not likely the machine.

I had a similar issue that I was using magnets as hold-downs and damaged my first machine, I found the problem when my second machine arrived and it has been working well for a couple of years now.

In any case Support will soon close this thread and work the problem out over email.


thank you. This is my very first machine. I stated this was my second ticket. I am just getting use to this forum and not being able to speak with a live individual.

1 Like

If you post in Everything Else you will not open another ticket, but support will not see it as they usually don’t read there. However, if you are seeking help from the community that would be the place.

Even in Emails it is good to reference the original ticket number so they can keep the tickets straight.


The three prong adapter is a problem, unless it’s been properly grounded. That might account for the power problems you’re having.

As for not cutting through, half-inch acrylic is a tough ask, since it likes to melt itself back together. I think it can be done, but only with multiple passes and careful setting-testing.


Agreed - the three prong adapter is an issue. You should always properly ground it if you can.


Hello @iyomi_fashions I am so sorry your Glowforge printer is not fully turning on. I can definitely assist you in resolving this.

I saw that you messaged us in a separate forum post. I wanted to let you know that I’m going to go ahead and close that and reply here. While looking over both posts it looks like you were able to resolve the Interlock Open message, is that correct?

Your Glowforge should be plugged directly into a grounded wall outlet that meets local building codes. If you haven’t already, please do the following:

  1. Unplug your Glowforge from the wall
  2. Plug another device directly into the same outlet and see if it works
  3. If the device does not work, have an electrician investigate. It may be a blown fuse, a broken outlet, or something else
  4. If the outlet works, unplug the other end of the cord from the Glowforge unit itself
  5. Inspect both ends of the power cord; if you notice any damage, try another power cord
  6. Plug in the end of the power cord that goes to the Glowforge, making sure it is inserted all the way in
  7. Plug the other end of the power cord into the outlet, making sure it is inserted all the way in
  8. If your Glowforge still won’t power on, try another outlet

Let me know what you find!

1 Like

No, the computer will not come on at all. It is completely dead. It started with the interlock issue and now it no longer works. I am working with David now via email. Thank you so much for responding.

I have completed all of the check points above and there is no electrical issue on my end.

Thanks again!

Thank you! I will look into the 3 prong now. It cut the .5" acrylic with ease it just was off on the measurements.

Thank you. I plugged it into a 3 prong plug and still nothing.

Unfortunately if it was damaged because of not being properly grounded, then plugging it into a 3-prong outlet after the fact isn’t going to fix it. :frowning:

The measurements of your cuts being off could be due to the artwork not being exported at 96 dpi when you created your SVG file. There are several ways to fix that – one is to export at 96 dpi. Another is to save as PDF instead of SVG. Another is to always use a 12x20" canvas in your design program – the GF recognizes those proportions and will import at the correct size.

1 Like

This was a line made on the GF app. I did not import a file.

We just tested it wit a ground tester and the outlet is good.

I get that. But if the GF was damaged by not being properly grounded (that’s what that third prong is for that the 2-prong adaptor eliminates), the status of the outlet isn’t going to make any difference.

If artwork created in the GF app came out the wrong size, that points to maybe the material height setting being incorrect. Did you have the honeycomb tray in when you did the cuts?

I am using the GE Polarized Grounding adapter.

Is there a grounding wire running from it to grounding screw on the outlet?

It is grounded and screwed into the screw on the wall plate. I read it needed to be grounded before I received the item so I made sure I had what I needed. I read the entire manual they require you to read before using. I avoided using my surge protector for that reason.

Yes, and it is screwed in.

I never stated that I used the adapter to convert from a 2 prong. I used the adapter because it stated it was grounded (extra protection for my $6000.00 investment) and it was hooked up correctly with the screw. I also stated that the other outlet had a surge protector connected. I am not sure if they make 2 prong surge protectors but if so I would have to believe that is a glorified extension cord, I could not trust my valuables with that. We did try another 3 prong outlet last night, which was the GFI in our bathroom and it still did not work.

My husband used his 3 prong plug outlet checker to verify if the plug I was using was grounded and it lit up correctly for a grounded outlet. You came to the assumption that was the issue for it being damaged but you never asked if it was a 2 or 3 prong plug. My OCD kicked in and I wanted more protection for this investment I have been reviewing for over 2 years before I purchased it.

Oh also, as for the .50" plexiglass, from my understanding that was the max that can be used on the tray so I did not remove the tray. I am not for sure if that happened with my cutouts I made as it was not a huge deal that they were cut in a precise place on the board. I have seen a lot of GF owners complain about that on this forum that they are having the same issue.