My Glowforge has dropped off the network every day for a week now

Almost a year into my GF journey I have had a strange occurrence. Each morning… offline. Run through setup and it connects fine… Gone the next day.

Do you keep the :glowforge: powered on? I know when mine goes to sleep it’ll often show offline, but when I wake it up it’ll reconnect. If you’re getting that right after a powercycle that’s different, but if you’re coming in to a machine that’s been on but unusued that might be it

**You might say something that covers this in the video, but I don’t have sound so I can’t hear you :slight_smile:

I don’t think other people are reporting that problem so I would suspect your network. Is your school IT doing something funky every night?

1 Like

IT said he has not done anything different. I am scouring the room to see if I plugged in a 2.4 ghz toy last week I forgot about.

I do not keep it powered on. Is that recommended? I may try it tomorrow just to see if I stay on the network. I came back to school tonight and she is offline again.

No - I mean, I don’t think they recommend one way or the other - but the going to sleep only happens if it’s powered on but unused. I turn mine off except when using it - others leave it on.

1 Like

1 Like

As @MechanicalGoose just pointed out (thanks, and sorry I’m late to the thread), we’ve identified the cause for this issue and are looking into a fix right now. In the meantime, the workaround is to perform Wi-Fi setup steps to reconnect each time the “Offline” message occurs:

  1. Power Up: Turn your Glowforge off. Then turn on your Glowforge and wait about 30 seconds.
  2. Start Wi-Fi Setup: Hold down the button on your Glowforge for ten seconds, until it glows with a teal color.
  3. Sign In: Using a Wi-Fi device like your laptop or tablet, go to and sign in.
  4. Connect Your Glowforge to Wi-Fi: Follow the instructions at to connect your Glowforge to Wi-Fi.

I’m terribly sorry for the trouble, and we’ll update the statuspage with new developments on this issue as they happen.


THANKS!!! Nice to know it is not me. =) I will keep an eye on the post for a fix. Thanks again!

We just finished up some maintenance that should take care of this. Could you please refresh your browser if you’re still running into the “Offline” message, and let me know if the trouble clears up?

1 Like

At home, but will first thing in the morning! Thank you!!!

Thank you for taking the time to try to see if the same behavior occurs.

Please let us know how it goes!

1 Like

=) It fired up and is ready to roll… or slice… =) Thanks tons for the support!


This is fantastic!

Thank you for updating us, and working so closely with us to narrow down the snag. I’ll close this thread for now, but please don’t hesitate to reach out to us directly at if you run into any more trouble.