My Glowforge is "lost"

I have literally tried everything in this forum, wifi, removing everything from the bed, resetting under the camera, belt tension. Everything. I took it apart to clean the air assist fan for the first time and now it can’t find its way, it keeps getting stuck on homing. Please help.

Any overhead lights or sunlight shining into the machine? It’s possible for those to cast odd shadows and cause the algorithm to misidentify the head causing it to move erratically trying to home.

You could also try turning off the system, putting head under the camera, and turning back on. That may improve the chance of recognition.

It may be a remote possibility that the camera has failed in a way that the system isn’t identifying that it has failed, but only support will be able to look at those images to tell for sure.


Oh. If you took the air assist fan off, make sure that the belt isn’t twisted. That will cause it to not move as far as it’s supposed to move so it will have a very difficult time getting to where it needs to be.


This was the problem! It was installed backward so the teeth couldn’t grab. Thank you.


Hello! @laceykate I am glad our patrons were able to help you get this issue resolved. I will go ahead mark this one as solved. Thank you for reaching out!