My printer head is moving but laser isn't firing and tube isn't lit

I ran a cut file tonight and everything was good. I flipped the piece to do an engrave and it engraved a very small bottom portion of the file and nothing after that. The print head moved like it is engraving but no laser comes out. I have disconnected and reconnected the ribbon and still nothing. I noticed the tube is not lighting up either. This is the pro machine and I have had it for less than 2 years.


After turning off and letting it sit for a bit, I grabbed a piece of proofgrade I had and put opened the good measure file. I checked and the power settings are correct. It went through the all the normal steps it does when I hit print. The laser still doesn’t work and the tube is not lit. Also, it was making a clicking noise as it went back and forth. I had the fan a bit lower than normal, but I have never heard this noise when the machine engraving. Shortly after it started the file, it paused and said there was a bump. Now it says there is an obstacle.

Another owner may chime in with some suggestions or more insight, but support no longer monitors this forum, so I suggest you contact support@glowforge.com with this information. Best of luck.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.