New forge, new thread?

I received the replacement forge yesterday. Unfortunately it is not working. I replied to the support/shipping email thread. I don’t know if that ticket is closed because the replacement shipped. Do I need to open a new ticket for the replacement?


Just what are the issues? It is easier to make suggestions if you say what you have done.

I would go to the glowforge support tab on the company website and try the chat option.

1 Like

No workie - The lights on the right hand side don’t light and the lid reports as open. I have included pictures and descriptions in the email but don’t know if that just goes to the dead ticket pile. I was just looking for the correct way to submit it since it is and isn’t an ongoing issue.

Yeah that’s probably a good place to head at this point. I never knew it was there because every time I visited the support page it was on the iPad and the option wasn’t there.

1 Like

Sounds like a bad rear ribbon problem. The first thing I would do is inspect that for the reason it was not connecting.

On a positive note I approve of the upgrades to the packaging. The setup was also much more streamlined and worked very well. Oh, and the lid closes much better, the old forge was always slighting offset so I had to make sure it was closed all the way before going back to the computer (in another room).


Yep, did that and sent pictures to the original email thread. This machine is right out of the box so I didn’t want to start messing with anything until I spoke to them. Everything looks in order from a visual inspection.

1 Like

I did have one occurrence when the lid reported open when it was absolutely closed, power cycling fixed it. That was only about a week ago.

is usually where there is a problem if it was not put in exactly right, either a bent pin or almost but not quite connected. It would be nice if @dan had a last min checkout that could run a test of those connections through the head ribbon would not be attached.

Being a new unit you can be assured I power cycled it a few times. :wink:


Not to mention the row of lights not working.


My understanding is that it is a refurbished machine so it would have been through a check of some sort. It happens, but it is still frustrating. :slight_smile:

The row of lights not on and lid open points to that ribbon. Better to operate under a dark wall than under windows but that is not reflected of your problems,

1 Like

The location is the same place the old one was for over a year. I suspect the connection in the bottom right corner of the lid is the issue but I’m not going to mess with it until told to do so. :slight_smile:

Sorry that was a joke as the sun coming in caused a different set of problems

Yeah I remember some of the early units having issue with placement.

OK, we have picked this up in email. This thread may be closed.

Thank you.

1 Like