New Glowforge, but only one of us can access it


#1

My wife and I received a replacement Glowforge as our first one appeared to be damaged in transit and wasn’t functional. My wife logged into the new one, set it up then invited me as a full user. I received the email invitation but the new Glowforge doesn’t appear in my printer list. When I try to add it through my account settings it tried to set it up as new even though she’s already set it up. How do we fix it so I can use it?


#2

Hmm. I’m not sure whats going wrong here but if she already set it up and invited you then the email you recived from her should be all you need. You shouldn’t have to set it up again.


#3

I’m having a similar issue. The people I invite are getting the email, but they stay as “Pending Invites” and not moving to “Users”.


#4

You used this feature if I remember correctly, right?

Did you use the same email tied to your existing GF account?

The email was very sparse as far as the next step after receiving the invite - did you just go to app.glowforge.com and the printer was set up already for you?


#5

Yep same one.

I clicked the link in the email and it took me to the support page. Then I went to the app and it was already there.

This may be a permissions issue. It might have only worked for me because I haven’t goten my email yet. For example, I don’t have store access.


#6

Ok. I only had one link in the email (in the line of: you can learn more about working with multiple Glowforge printers here) and I get a 404 when I click that link.


#7

customer support be like…


#8

I didn’t have a link in the email that took me to the app. Just a link to the support instructional page.

We set this Glowforge up with my wife’s account, our last one was setup with my account.


#9

That might be where the issue is.

I’d let support take a stab at it and make sure you are logged in at glowforge.com with the correct email before you try and go to the app.


#10

I agree with @soldiercoleman because you have used 2 different email addresses on 2 different configured GF :glowforge: units, the automated setup process will see a deactivated GF :glowforge: tied to your email address.

@Rita will have to manually purge those references for the automatic processes to complete the setup.


#11

I think it might be an issue on there end. I invited 2 people. Both of which are still pending, but I have no idea what is pending.


#12

What does the screen shot show on the “Pending Invites (2)”?

With the email addresses obscured.


#13

Nothing much. There’s no link in the email to accept the invite, and there’s no where for me to approve it.


#14

These are non-Glowforge owners/registered email accounts, correct?

What happens when it is sent to registered/owner account that does not have a GF yet?


#15

One is a non-Glowforge owner, one is a registered owner.


#16

Did either of them get a notification?

Was there some sort of instructions for them to follow/do?


#17

Both got emails. Not really sure what they said, I haven’t seen the email.


#18

Do you have an additional email address (that is not related to Glowforge) that you can send an invite to and see what the invite says?


#19

The email says:

Thanks to Joseph (obscured last name), you’ve got access to their Glowforge, which they’ve named Stormageddon. The top-right corner of the Glowforge App shows you which Glowforge printer you’re using. You can click on it to change.

Decisions, decisions. You can learn more about working with multiple Glowforge printers here (obscured link - I don’t know if they want it public. It 404s for me). In short, you can view what’s on the bed, print, cancel prints, and otherwise treat it as your own.

Joseph has also granted you full access to this Glowforge printer, so you can return the favor and invite others to use it. Remember, they’ll be able to print to it invite other users as well, so be careful who you add.

You can add users at any time with a new add users button on your Glowforge Dashboard. Every new user get their own dashboard, will have their own account to purchase with, and won’t have access to your designs.

Happy Printing,
Glowforge


#20

After they got the email, did they complete the registration process? When I did I had to log in and click ‘no password’ then follow the instructions.