New UPDATE : Camera is working very slowly

Being that I use my Glowforge everyday, hours a day since I have gotten it, I have noticed that the Camera that shows the display is taking longer and longer to display.

This is very annoying , and frustrating as now with every time I open the Lid I have to wait work on the design from memory and than after its done scanning , and ready to PRINT the camera shows up.

This is a no good, How can I go Back to the other UPDATE that worked flawlessly for me.

How often are you cleaning? It might be trying to focus through a bunch of smoke residue, I haven’t noticed any longer processing times lately.

1 Like

Could also be a spotty wi-fi issue…

No, I have ruled that out, takes 15 seconds extra now for the camera to load, is is the new update with the snapmark now that is causing this. How long does it take your camera to load the picture after closing the lid ?

I don’t know, not too long. I haven’t timed it. I’ll try to pay attention next job I run.

1 Like

Just so you know , before the update it was almost instant.

I’m confused as to how you are determining when there’s an update. It’s not like they tell us.

I have the snapmark that appeared on my tool bar.

I had that on my previous machine, and didn’t notice any slowdown.

I can say this: Snapmarks shouldn’t interfere with the camera operation. It’s a software switch in the UI, not a firmware update on the machine. And it’s only active when you hit the button.

But that is only change that was made on my Glowforge or computer, any other ideas as why its taking so long for the Camera to show, I have 100 meg internet , so im ruling that out.

No idea. I’d reboot the router just because though. Glowforge in same place?

Btw, if you think it’s related to snapmarks, you need to post it in the Snapmarks thread. If it is related, customer support won’t be able to assist (they aren’t trained to help with Snapmarks/beta stuff).

Internet speed isn’t the issue. It’s wi-fi connectivity.


Could it be that i am using the 5G signal rather than the 2.4

GF needs to be on 2.4.


Mine takes about 15 seconds.

1 Like

Love love love is all i can say, Thank you, that was the release of my chains.


It won’t work at all on 5G, so that doesn’t sound like a reason.

1 Like

That is what I was led to believe also but it is working on the 5G for me.

I have tried it back on the 2.4 but the results are not that much better, i have to believe that something changed with the snap-marks being introduced, as if the machine has to think longer .

Something is different.

That’s the connection for your laptop, not the Glowforge.

The Glowforge won’t connect to a 5ghz network. A lot of times though, routers will dual-broadcast 2.4ghz and 5ghz on the same SSIDs.