"No Artwork" message - UI doesn't recognize JPG, PNG, PDF, or SVG

Starting early this morning the GFUI doesn’t recognize any file types I load into it (whether they be new files or ones I’ve used successfully before).

I’ve tried JPGs, PNGs, PDFs, and SVGs - all say “No Artwork” even though the items loads visually - and nothing shows up on the left in the various fields there except the initial engrave, etc options.

When I choose something other than PG engrave on the right, the image then shows up in that box, but still “no artwork” on the top right.

As far as I can tell, I’m dead in the water because it doesn’t recognize anything.

I have power cycled the GF, rebooted the computer, refreshed the bed image, refreshed the browser - no change.

This appears to be the same problem I have experienced–and reported–and that I have seen others post about as well. When it happens, closed paths appear as black filled instead of showing the actual path in the GFUI. Have you tried creating a new job from scratch? That usually fixes this particular issue.

To be clear, I don’t mean recreating your image, just creating a new job in the GFUI and reimporting the vectors you want to use.


Good feedback.

Yes, I’ve done that as well many times, but I just did it again and things appear to be working normally again. Not sure what to make of this or what’s been going on most of the day…

I wish I could give you more info, or that I could tell you that always fixes it; it doesn’t. But most of the time that it has happened to me (including once today), recreating the job works. It seems to happen to me most when I reuse a job, especially if I make any changes to the vectors–e.g. importing additional vectors or deleting and re-importing the vectors because of changes I have made.


I really appreciate the help and dialog! Thank you for everything!

1 Like

If it’s any consolation (it isn’t), I’m having the same problem, except that I can see a thumbnail of my artwork on the left panel, but there’s nothing over on the bed image and the “button” area to the upper right also says “No Artwork”.

Starting to wonder if maybe it’s a new back-end bug, frankly. Rendering also seems to take longer today.


That happened to me today as well on my work machine. It was a jpg, and I eventually got it to work by printing it on a xerox and scanning a bed image. The quality wasn’t great, but we were happy to have something for our program tomorrow

I see you created a new thread about this issue. Since we’re following up there, I’m going to close this thread.