No power :-(


#1

Hi. I received my GF pro a few days ago, and was so happy to start printing !

The box was not in perfect condition when it arrived (dirty, scratches and all handles missing) but all was OK inside.
So I unboxed, installed an air extractor and dedicated power plug next to the best place in a large basement room, well ventilated and with constant 21°C temperature, on a steady table.

I removed the shipping anchors and orange tape, connected the head, and exhaust hose. Plugged in the wall outlet with the provided cable and flipped the switch. Everything OK.

When I started the set-up, I could see the the GF wireless network appear on my mac and I connected to it. The bubbles in the tube… and a little pop ! Power went off, the lights & network disappeared, no arm moves, nothing. Tube seems intact. I could read a message on the mac saying something like “cooling alert”.

I tried to unplug, waited for cooling down, pressed the dead button for 10 seconds many times, waited again a full day, changed the power cable and source, checked the interlock, tried again and again but nothing. No power, no lights, no move.

As I am in Paris (France), sending it back is very bad news. Huge delay for my professional projects, and a risk that I would need to pay 1650 USD again for custom taxes if Glowforge sends me a new one.

Is there anything else I can do ?

Thanks !


#2

I think you’ll need to hear back from Support on this. But I think the “pop” and power-down are a bad sign.


#3

On the back of the machine above the power switch, there is a little black circular rubber plug with a staple in it. Unplug the machine, and make sure that is pushed all the way in. Then try plugging it in and turning it on again. (And good luck!)

Oh wait, maybe that was the interlock and you’ve already checked it. Well try again anyway…can’t hurt.


#4

I don’t believe that will kill power to the machine. It acts as an e-stop and just kills the job, like lifting the lid.

Have you plugged anything else into that dedicated outlet to see if it worked?


#5

Thanks for the tips.
I did play with the circular rubber plug (interlock) and pushed it firmly inside.
I did plug a lamp in the outlet and it works fine. I also tried with another outlet connected to a different circuit.
No changes. Still doesn’t power up…


#6

Oh no! I’m so sorry you ran into trouble so soon.

Just to be sure, have you tried unplugging and replugging the end of the power cord that goes into to the unit and turning the unit on again?


#7

That pop sounds like a power supply capacitor blowing kind of sound.


#8

@jaz Yes I have, many times…


#9

Thank you for confirming that.

Unfortunately, it looks like your unit is experiencing an issue that we can’t resolve remotely. I recommend we replace this one. I’ll be in touch via email to sort out the details. I’m so sorry about the bad news.


#10