Not connecting to internet

Has anyone else had a problem connecting to the internet? I can connect to the sales site, but not to run my Glowforge. I’ve shut off both units and let them reset and nothing. I’m really getting frustrated with this! I have a big show in a few weeks and can’t spare a minute of down time.

When I go to I get nothing. Sounds like same issue.

Did it get resolved or do you still have the issue?

All dandy here. Either fixed or only affecting part of the internet. (I’m east coast btw)

Strangest thing. I seem to be able to see it from my phone but when i try to go in through safari on the mac. Nothing. Never had this before.

Just got back in. Not sure what that was.

Thanks Paul, I’m in California. But everything else is working, I don’t get it!

Where do you live Brad? I live in California and have Spectrum for internet and they really do Suck

Indiana so I doubt it was the same issue. The only thing i did differently the time it worked was to right click and hit reload page. I had been going in through the search bar. I really don’t know that it had anything to do with it or not.

Ok I thought it was just me, but the GFUI does not come up for the past couple hours

Can’t connect here either. I’m in San Diego County.

Apparently the Glowforge Status page is incorrect in saying everything is operational

I am in Tampa, everyything was working earlier in the day

1 Like

It doesn’t seem to be working on Chrome but I logged in on Firefox and it seems to be working fine. I’ve been trying to use the app for about two hours now, don’t know why this thought just occurred to me…

1 Like

Not in Android either

California, Chrome: Have been cutting and engraving for the last several hours with no issues.

1 Like

Ditto here…Texas, Chrome.

1 Like

Thanks, I’ll try it

I use Chrome. As long as I didn’t close the app I could use it. I opened a second browser window which would not open the app. Still cannot open the app (on my computer).

Thanks, I tried Firefox and it worked!!! You are awesome!!!

Weird I cannot get it working on the Tablets or computer but it works in chrome on my CELLPHONE!
tiny as it is i was even able to start the glowforge but had to abort as it was too tiny and difficult to align the work properly.