"Not Enough Snapmarks"

Hey there!

Yesterday, snapmarks weren’t working at all. I’d hit snap, it’d attempt to snap and do the calibration (the head moved) but then when it was done the art wouldn’t snap into place and there was no error.

Today, I’m getting an error saying that there are not enough snapmarks, but there are.

I know this is technically an unsupported feature but I see in the forum that you did some sort of update that may have caused the issue yesterday. Is the issue I’m having today, in relation to that?



1 Like

The last time I used Snapmarks was August, but I saw that message then. To me it means it is only seeing one of the snapmarks on your jig, or it cannot find two snapmarks in the file you are using.

Sorry I don’t remember exactly what I did to clear the error, but it wasn’t much. I would have tried:

  1. Opening and closing the lid and trying again.
  2. Deleting and re-uploading the file.
  3. Cleaning the lid camera and lenses.
  4. Moving the material a little bit.
  5. Trying again using Set Focus.

Again, I don’t remember what I did, but if it wasn’t one of the above it would have been unique enough I would have remembered. I do remember thinking, aw *&^%$^ my Snapmarks are broken, but they weren’t.

As @caribis2 noted, either snap mark may not be seen…

Is this a file you used before and it worked? If so, hmmm.
Even if so, shifting the snap marks closer together and ensuring within the area for the etching/cutting area should help, as I recall even if the positions were correct, but one was outside the effective area, the camera would not see it–so hopefully it’s just shifting the material a bit to ensure they’re in. Alas it might mean you can’t pack in as many items for cutting/etching to ensure it works!

I’m sorry you ran into trouble while using the Snapmark tool. It looks like you’ve received some great advice from our other community members. Thanks folks!

I extracted the logs from your Glowforge and it looks like you may have tried running this print again. Did the advice provided lead to your print running as expected?

I think I’m ok, for the most part now. It seems to be very hit or miss whether the GF recognizes the snapmarks or not on the same file. We use a single file that matches our jig that we swap the content in and out of it, sometimes it snaps and recognizes the SM but sometimes it doesn’t. I just make do. :confused:

Depending on the material you’re engraving, you might need to clean your camera lens more frequently. The next time that you unit has trouble recognizing the Snapmark symbols, would you please do the following?

  • Open the lid of your Glowforge
  • Clean your lid camera lens with a Zeiss wipe
  • Try your print again and see if the symbols are recognized as expected

Please let me know how it goes!

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.