Not firing, tried everything

We are in a pickle and could use some help until we here back from GF (however long that may take). About two weeks ago the GF only cut part of a file I bought on Etsy. Thinking the GF needed to be cleaned anyway, we waited to try the new file the seller sent. Earlier this week we went through and slowly cleaned the GF following the instructions. It is now not firing, and not light in the tube.

This is what we have done/noticed:

  • Went through the cleaning process a second time

  • Checked the power on the file

  • Tried different files and shapes in GF

  • Checked that the mirror is installed correctly

  • Checked the tightness of the belts

  • Tried proofgrade

  • Checked all 5 mirrors

  • Took the head off and check the pins to the ribbon

Any other things we could try? Iā€™m desperate to get this to work

Do you have a photo of the almost cut? Did you hear a sound at that time? Does the Glowforge go through all the motions, just not cutting?

I can think of few options that do not entail a trip to the mothership unfortunately :grimacing:


did you try running a Gift of Good measure?
did that pass or fail?



@cass I feel your pain. I have everything that I did listed out in my post here: My GF, Eitri, is unwell

Hopefully you can find some insight or assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.