Not rendering designs

Trying for two days now to upload a simple vector, it goes to rendering design and stays there, watched for over an hour at a time and no change. HELP.

If you upload a zip of your file, I’ll bet somebody could help diagnose… Do other files work fine?

Are you able to load Glowforge files, like the metric Gift of Good Measure?

Have you tried a different browser?

Not tried that as yet will do right away.

1 Like

No just google chrome, what would you recommend as the best second option.

Whatever you have.

Chrome is recommended but trying something else just to test rules out a problem with it. There’s no issue with their systems.

No issues all brand new and was running fine till two days ago, I will try a different browser just now.

Tried Firefox still nothing, tried uploading the gift of good measure still nothing.

I have no other ideas, sorry. There’s no current issue with their systems, and I’ve been using it pretty heavily the last couple of days without issue.

Cheers anyway, will continue to try other avenues, been on to support so maybe they can help.

Posting here also opens a support ticket, but they’ll probably close this one and continue by email, so let us know what it ends up being!

Will do, funny thing is I just uploaded a simple circle vector, and it worked fine, any other designs however simple are not being rendered, Strange.

I just tested a 400kB design with ~3500 nodes, it took less than a second to render.

Once the design has uploaded, the “render” part is all in the cloud (the machine does not even have to be turned on - mine isn’t right now) so I have no idea what could be causing it.

strange indeed.

Just figured it out, I am a plumb lol, saving to wrong file type in CorelDraw, all new to this so bound to make a few daft mistakes duh.


Got it stupidly saving designs as wrong file type duh. I am a NOOB at all this. Thanks for the help.


Glad you figured it out.

1 Like

I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!

1 Like