Odd behavior with PNG and tool bar-resolved but FYI

This has been resolved, but wanted you to know about it becasue I keep getting new little odd behaviors like this and this is not normal for my GUI. The little blips seem to be related to set focus, but that just may be coincidental I guess. This is the only image I have of it and hopefully you can see what’s going on.

-Today at appx 2050 hrs I loaded the below dog PNG and it looked normal.
-material is tile painted black
-Used set focus and seemed to work. (Although no way to know for sure since it doesn’t tell us the height. It would really help for it to do that BTW.)
-went to put in manual settings and the image almost completely blacked out as you can see in the right edge of the pic.
-changing setting from vary power to dots made no changes and it stayed blacked out regardless of my adjustments.
-When I tried adjusting the dot range, the slider didn’t work and all that showed up was “NaN” under the density bar.
-Reloaded the dog file and it happened the same way again.
-Played around for a bit and the error cleared. It then worked as usual except for the scroll bar on the slide-out too bar is now in an odd position. .


Working correctly except for odd scrollbar placement


Sounds like a browser rendering error.
Close the browser to app.glowforge.com and open it up again.

That doesn’t fix it. Whatever it is, it seems related to the new set focus operation and it’s not so much about how to make it go away, it’s to let them know it happening. I’ve reproduced it again today. I manipulated several files and it did not occur until using SF. Just did it again today. (5/10/19 @ 1200 hrs.)
-Refreshing bed did not help
-Reopening the app page no change.
-Went back to the home page and reopened design and no change.
-Closed browser (Firefox) and reopened and no change.
-** kinda interesting… It showed no change after reopening etc. Then I tried opening up the convert to dot settings again. Clicked the dot pattern density bar and the “Nan” error went away and it began working correctly, then the file image fixed itself and look correct again.

Below image is AFTER closing browser and reopening from home page. Opened the setting slideout, clicked the convert to dots>dot density and error cleared.

I’ve seen this happen before too. The Glowforge UI does some weird stuff to hide the scrollbar on the list of operations and sometimes it doesn’t work so well.

I wish they’d just stop doing that and allow that list to have a visible scrollbar; the hidden scrollbar causes a lot of problems for people using mice without scroll wheels. (Or for those with disabilities who are using assistive technologies.)


Thanks for letting us know. We need a bit more information to investigate. Please do the following:

  1. Go to https://www.whatismybrowser.com/
  2. Click the link underneath “Share my system info with tech support”
  3. Copy the highlighted link
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.