Offline Glowforge


Since 2 days I can’t use the Glowforge…I get the message: Glowforge is “Offline”.I tried everything you wrote at Troubleshooting-WIFI but nothing works, I still get the same message of Glowforge is Offline…Please help me in this situation, I have orders for customers that I have to finish by Wednesday…
I’ve tried all these things and it still doesn’t work!I’ve tried absolutely everything you write on the Glowforge website and nothing works!Please help me!
The button doesn’t turn teal and my Glowforge doesn’t broadcast any temporary access point.I have orders for customers that I can’t execute, I lose money!!!

1 Like

How long have you been holding the button down? It takes a good 30 seconds or so before it goes teal.


20-30 sec….

And still no teal…

Just for giggles try a full two minutes.


I’m so sorry to hear your Glowforge button is not working. Thank you for letting us know that the button does not turn on even after holding it down for 20-30 seconds. I have responded to your email ticket about this issue. To avoid duplicate communication and expedite your process, I’m going to go ahead and close this topic.