Oops, Compact Filter Switch on with No Compact Filter!

I noticed the ‘Compact Filter attached’ option in the GlowForge app today and was playing around with it. An hour later, I started to cut something and noted that the GlowForge is a lot quieter. It took me a little while to realize that I had left the ‘Compact Filter attached’ option turned on. My GlowForge is attached to a long 4" duct in the wall with an inline booster, so the smoke was (slowly) exhausting.

Correctly set to ‘off’ now, but it is amazing how quiet the GF is without the built-in exhaust fan running.


This is why so many have added the external inline fan. Once it is hooked up and running you do the same thing, activate the ‘compact filter attached’ option which drastically reduces the noise.



1 Like

Yeah, I pulled the same trick a couple of weeks ago…filled the office with smoke. :roll_eyes:

1 Like

Just so I’m not crazy Jules, the Compact filter is the same thing as the Glowforge Air Filter I just recieved right?

Also, since I figure you’re the guy to know, it says to not use high particulate materials like MDF or draftboard with the air filter…would solid wood plywood be ok you think?

Also, the air filter beeps at me everytime I turn it on, is that normal? the manual seemed to indicate that meant it was full but it’s brand new.

Not officially. They said the GF filter is an improved design with more power and the ability to use a pre-filter although they’re not shipping with a pre-filter.

@jules is a girl (I’d have said a lady but she disagreed with that characterization once) :slightly_smiling_face:

Solid wood plywood like Baltic Birch which is made from veneer plies don’t have MDF cores so shouldn’t have the filter clogging properties of Draftboard or PG Plywood.

What happens if you turn the fan up a bit?


It beeps at me regardless of the setting. Seems to work fine though.

And just so we’re clear, it’s when I press the power switch it beeps. If I leave it “on” but at no airflow and then turn it to the lowest airflow setting by “new” it never beeps.

1 Like

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.