Orange Button - White Print Head Cable

So today I ran a print. Everything was going fine 20 minutes in. Gte notified the GF stopped printing. Saw the GF had an Orange button, looked it up, opened the machine and say the Print Head cable was unplugged. Weird.

Plugged it in, started a new print and about 30 minutes in, same thing. GF had an Orange button, looked it up, opened the machine and say the Print Head cable was unplugged.

All the pins seem to be straight. Cable female side looks good. Cable clicks into the housing and seats well. I tried put a little force behind it and I can’t even pull it out. So it is sitting well into it. Seems that after multiple passes that the cable clicks out of the housing somehow.

Pics of Pins/Head:




It must catching on something. I would run it again and watch it like a hawk to see where or what it’s catching on.

I thought of this. I am not sure what it could be catching on though. There is literally nothing near it.

EDIT: I am cutting something right now. While watching it you can see that it has about an inch of clearance above the cable and the retaining clip. There is nothing there for it to catch on. If it was catching on something it should fall out around the same place in the same print/same time. The first print lasted 20 minutes and the second 30 minutes. I am wondering if the retaining clip is just vibrating loose after some time and it is falling out.

EDIT 2: I should add I had to wedge a small plastic piece under the retaining clip to make sure it will seat all the way. 10 Minutes in on this cut and it is still going. But, I would rather not need to McGuyver the machine in order for it to work.

I remember reading a post once that a screw behind the cable once backed out and caused a similar issue. one of the screws that holds the black cover on that the while cable rests underneath. Maybe it could be that?

I do not see any screws in the area of the white cable. Thank you though.

1 Like

These are the screws I’m talking about.

Thanks for the photo. I didn’t put two and two together. It has been a frustrating day. On topic though, I went in with a appropriate sized tool and they are very tight. None of them are in any way shape or form far enough out for the cable to latch onto them. Thank you again though!

1 Like

Np hope you get it sorted soon :beers:

Same here. Jerry-rigging the machine sucks. I am never going to be sure if it can finish a multi-hour job. Thank you again for all your help. I appreciate you!

I’m sorry that you’ve run into persistent trouble with your Glowforge. Thank you for letting us know that you already checked the ribbon cable’s connection on the head and shared a photo of the pins. It’s a bit hard to tell in the photo, but it looks like the clip on your ribbon cable might have a crack in it:

Will you please let me know if the plastic appears to be damaged at that location?

So it does look like it has a small crack in it. When I attached the cable to the board it “clicks” but just not as loud as it used to. It’s more of a sad “snap”.

It’s hard to explain.

Right now I have a very small piece of wood wedged under the clip to have it working. I can’t afford to not have this machine running right now so I had to jerry-rig it.

I am not sure how it cracked as all I do is take it out and plug it back in when cleaning. I build computers and know not to use much force when connecting these cables.

Anything I could do? Or can I get a new cable from you guys?

Do you need another picture of the crack? I can try to get a better shot for you after it has finished cutting in a bit.

So my machine just now said something “bumped” the print head and it paused the print. Said to check to see if something was in the way of the print head. I checked it and nothing was in the way. So I pressed the button for it to continue cutting. It has 2 minutes left in this cut after 2 hours. I would hate for it to mess it up now.

Thank you for sending this information over, and the temporary fix you have in place for the White Ribbon cable. This particular part cannot be remotely replaced. I’ve reached out to you directly via email to send over the next best steps, and I’ll now close this thread.