Page stuck on "rendering Image"

Hello Forum!
A couple days ago I decided to upgraded to premium, and ever since my Glowforge page/dashboard has been running super slowly. I thought it was because the project I was working on had many stamps in it, but I have had trouble with “create new” files also.

My BIGGEST issue is I just got a lot of things off of the “free catalogue” and none of them will load. Is it possible that I have too many files in my dashboard?
(BTW, I would love to be able to make groups to organize those files someday, coughcoughHINTcough) :wink:
Anyway, the page just goes grey and says “rendering image” and then never loads! Is it just me? I’ve tried restarting everything, even resetting my internet connection. Other pages seem to be working fine though.
Advice would be appreciated. TYIA!

Sounds like your cache may be corrupted.

See if you have the same issue if you try from a completely different browser (like Firefox instead of Chrome) - or clear your cache (if you don’t know how, Google “clear cache [Name of your browser]”)


Thank you, I’ll try this

I’m getting the same thing this evening. I’ve cleared the lens etc. I’ve restarted. Tried a simple line file from Inkscape, Ai and just a regular svg file … nada… making me crazy. I’m using safari.

Thank you, this fixed my problem I think! I appreciate your help!


Hey @lizzymayhem,

I’m glad to hear you were able to resolve the issue with @deirdrebeth’s advice. That’s great!

I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!