Parts of a step off-center from the rest of the step in one job

I’ve posted about a cut step being off-center from an engrave step in the same job before, but with no help offered from Glowforge… Can we try again?

I have a print of many circular game pieces, which I make by running a job that’s Engrave many pictures + Cut many circles.

Here’s an example of three “identical” pieces (they’re duplicate objects in the design) that came out differently when printed, and this time it’s obviously visible:

This is not consistent - it is not predictable which circles, if any at all, will be off.

The piece in the middle looks correct - the engrave is centered with the cut, as expected from the design. The left one is slightly off, may only be able to tell in person, but the right is clearly cut off-center from the engrave.

What would cause this to happen during printing? The failure to properly cut the right piece does not affect the rest of the cuts that happened after it, though I’m not certain it was not the very last circle cut (this was a set of 30 pieces). But this happens often enough to know that one piece mid-run can be off, but the rest happen as expected.

Does that indicate a software error (where the circle was processed incorrectly and slightly moved during the plan of the print? This seems unlikely since we’re all able to consistently print such precise awesome stuff!)
or a hardware error (where for some reason the laser head moved into position for one shape incorrectly… but the rest of the print run is unaffected?)…?

Are the engraves raster or vector?

Do you duplicate the pieces in the GF UI, or in the design file?

This is very similar to an issue faced by another user, where raster engraves within a shape are “moving” relative to the shape when many duplicates are made. You might note the time of the print and the location on the bed of the ones with issues - support can access logs of the print and take a look at the underlying “code”…

1 Like

Vector, svg source files. Only thing done in the GF UI is moving the design into place.

I’ll be sure to document it right away after the next print without touching anything if any happen.

This is the thread I mentioned. They are “3D engraving” embedded raster images, but if you look at the first pic, you can see the engrave is offset from the hole cut.

It has to be software (cloud processing) because there’s no other way it would affect just a number of items. If it was mechanical (like a belt slip), they would all be off, or at least all from the point that one was off. Also, they wouldn’t print so perfectly, I feel.


Right? But unless it does it by trying to move into position X1 for a given circle and fails a bit, but then moves into position X2 but it’s not relative to the move to X1, so it can do it right? But then they’d be able to fix it because it’d be able to know it wasn’t properly at X1…

Unlikely - I was adding to my post above, they wouldn’t all print so perfectly.

It would be interesting to know if the offset is always in the same direction. It appears to be from your picture.

Is the engrave offset from the cut, or the cut from the engrave?

Good question… It definitely seems to be the cut because I can watch the engraves happen and all line up neatly, starting (and later ending) in the same pass.

And yeah, good point, if it’s a movement issue, seems like it’d also affect the shape of the pieces, and that has never happened. And I’ve made thousands of these!

Did this just start happening?

Nope, it’s been an issue since very near the beginning. I have found I have more luck if I run one row of pieces at a time (up to 12 pieces) rather than multiple rows (like 6 rows of 10-12 pieces) at a time. That is, usually this only happens when I run multiple rows at once.

That, too, appears consistent with the other thread I linked to. Once you get above about a dozen, it starts to go wrong…

1 Like

I wonder if the engraving is changing internal pressures in the wood and introducing slight warps here and there, which then throw off the alignment of the cuts? Have you tried running the cuts first and THEN the engraves? Then at least you’d have the pieces all (presumably) flat on the honeycomb when they are engraved…

1 Like

I’m the user eflyguy mentioned. In my case it’s certainly engrave issue. As there are 2 raster images embedded into SVG, it first engraves one thing on all copies, then another, them makes cuts. Defective engrave gets shifted even in regards to engrave which is fine and aligned with cuts. And seems that shift happens in same diagonal direction. If say 10 copies are made within single SVG file, there is no engrave offset.

If I see it happen again, I’ll have to try seeing if the cuts look like they’re off at all in the hardwood. If they look lined up, this is probably it!

1 Like

I’m so sorry to hear that you’ve hit this snag. I’m glad the community was able to help provide some suggestions. As @wraper mentioned, this may be due to the number of copies you are attempting to print at once.

Could you let us know if the same trouble occurs with smaller batches of copies, or is it still appearing if you print less than three?

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email