Perpetual Offline/Centering loop

This has been a problem of late. Most of the time it would clear up after about 15 minutes or so. Recently it has been just getting longer and longer. I initially thought it was a network issue, as I just switched providers. But I have since configured their router to allow my home network a clearer path, and still I get this loop.

It has, as in the past, ended the loop. I still feel there is something else going on. I have no other problems with any other devices on my network. I can stream High Def videos without the slightest buffer, stream music, watch my security cameras, etc. Monitoring network activity, I can see the glowforge’s data packet leave when it tries to ‘center’ the gantry. That burst isn’t even remotely large enough to be impacted by my network speeds. I even prioritize the glowforge for faster speeds and it still doesn’t help. I just have to wait it out. This points to either a hardware issue (Network card) or software issue.

I finally tracked down the cause of intermittent signal weakness to the poor performance of the WiFi half of an expensive combination Motorola modem/WiFi router. A $25 dedicated WiFi router connected downstream solved it.
Good Luck!


This is annoying, to say the least. It’s connected directly to my Google Hub, which is wired to my ISP’s router. Wifi on it has been turned off and my Hub has a dedicated IP address on it, as well as a direct passthrough. I had upgraded to fiber, which gave everything else in my house great connection. Well everything but the glowforge. I have no issues with it once it’s done centering. Makes me want to just leave it on forever.


You understand that fiber is your ISP, right, not your internal signal? The GF is having problems with your internal signal most likely from what we have seen reported by others with similar issues.

1 Like

Yes, I understand. If my internal signal was that weak, I would have stuttering music and video when streaming. I stream music to multiple smart speakers that are farther from my hub than the glowforge is. My TV is even on the opposite side of the house and no problems getting crisp HD videos. So not a signal problem, unless it’s related to the hardware on the glowforge. I’ve had more than a few years worth of network training. While I’m no expert, I’m not a layman either.

1 Like

The way you worded your post made me think otherwise, and it is an extremely common misconception.

We have found, as a group, that other devices cannot be used to judge the stability of the GF connection. Personally, I have less than perfect connection for all my other devices in the same room as the GF but the GF is rock solid stable. I would check the signal strength at the GF by using a network monitor app on your phone or tablet or laptop if those are available to you. A signal strength of less than -55 dB is usually not reliable for the GF.


Thanks for letting us know about this. Please note that your Glowforge is a legacy client device that uses 2.4GHz b/g/n to connect, so if connectivity issues are occurring, the same effects won’t necessarily be reflected in devices that use 5GHz. The Glowforge may still be more susceptible to environmental interference or band-crowding.

You mention that you’re using Google Hub for your network. If possible, could you please let me know if this issue resolves when you bypass Google Hub?

If you’re still having trouble, can you please let me know an exact time that this happened (including time zone) and how long the Offline/Centering loop persisted? This will help me investigate the logs on our end.

1 Like

It was happening when I posted this. About 8:30 CST and ended about 9:15 CST. Not sure exact time it stopped, as I was doing other things and was only periodically checking back on it.

Thanks for getting back to me about that, and I’m sorry for the late reply. It does appear that during the time you were having trouble on the 7th, the uploads your Glowforge was making to the cloud were expiring in a way that suggests the connection was unstable at the time.

I’d still be interested to know if you experience the same trouble when bypassing Google Hub to connect the Glowforge. If possible, could you please try this and let me know how it goes?

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email