Photo Engraving - Error Uploading

So I have a 6.5mb photo to engrave. I have used Lightburn to get the file into SVG format and only have 2 parts, an engrave and a cut. I can’t upload the file as GF gives me an error every single time. I have been working on this for the last month as I needed to prep the photo in PS alot as it was a business ribbon cutting on an overcast day with many of the people in the picture wearing dark clothing. SO lots of dodging and burning on the photo. I added an frame around the picture, exported it out to png, then brought it into imag-R. I ran it through and then saved it (all versions). I then brought it into Lightburn, added a cut box around it and exported out to an SVG.

GF won’t upload any of the versions I have tried. Yet last week I did another photo that was 2.2mb and last month somehow this same picture (minus all PS work and the frame and the but line was able to be uploaded and engraved.

I’d like to know what guidelines there are concerning photos for engraving. I can’t keep wasting hours trying to upload a file to GF over and over.

#erroruploading #photoengraveupload

Sounds like a lot of edits that may have created too large of a file. If you are able to upload other, smaller designs without issue then I would think the design is too big and timing out because it’s taking so long to load. Might be a wifi issue, but more likely just too large of a file. I would consider trying to load your image into Photoshop, shrinking the size of the image and/or the resolution. If it loads up with out issue after that, you’ll know that was the problem.

1 Like

That file is just too big to upload. I had a coaster design that did the same thing. The GFUI can’t handle a file that size. I don’t remember what I did to resolve this, but I got it working with a much smaller file size. It still takes 4 +min to upload and 1:37 to cut 4 coasters. If I try to upload more than 4 at a time it won’t do it. I even tried copy and paste once I uploaded 1 coaster file. The interface just won’t do it.


Could you not bring the photo in as a bit map? That would eliminate the nodes that are probably overwhelming the program.

1 Like

I was finally able to upload it, file size was 2.33mb. Had to go in and make a rectangle cut line around it in GF. Thanks for all the feedback everyone!


I’ve never used this service, what does it do that Photoshop doesn’t? Do you like it?

Hi @r.carpenter. I’m happy to hear you were able to get this figured out. I saw there were discussions in this thread, so I moved this to the Everything Else section of the Community to allow any follow up discussions.

If you run into any further trouble, feel free to create a new thread in Problems and Support, or write us at and we’ll be here to help. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.