Pleeeeees Need Help

My glow forge works normally everything is ok like normal sent the jop to the glow forge magic time the button is glowing i hit nothing happened i tried a lot no hope tried to reboot or check the wifi but the button is not responding to anything i contact support but no answer yest pleese help my as i thought of shipping to glow forge for maintenance but it will cost me 3000$ shipping only i don’t know what happened i am a light user maybe an hour every month thats it i thing my total hours on glowforge did not exceed 50 hours since buying it

Uh-oh! That sounds like the button might have gotten disconnected. Can you take a closeup picture of the underside of the button to see if there are any loose wires that you can see? (If so, post it here so Support can see it.)


i tock a picture

Hey @abd.hassouna

I am so sorry to see this happen to your Glowforge. I’ll have the team start looking for solutions to help address this problem. I see we have another ticket open which we will communicate from there. I’ll keep this forum post open in the meantime until the issue is resolved.


Thank you dear I am really worried as I am out of USA and stock with it

Hi, @abd.hassouna My name is Mercedes and I’m part of the Technical team here at Glowforge.

It looks like we were able to get this resolved via email for you. That’s great!

I’m going to go ahead and close this forum post now. If you have any other questions or need help with anything else feel free to send a message our way by either creating an email ticket or a new forum post!