Power cord / power connection

Does anyone else have problems with their black power cord? I’ve had my pro for about a week and I have been having to wiggle the cord to get power to the unit!

That’s not good. You’ve opened a support ticket by posting in this section, so they’ll be along soon to get you fixed up. :slight_smile:

1 Like

Have you tried a different power cord? It is a standard cord such as those used on personal computers.

3 Likes

If you have something else that uses that power cord, plug it into it. That way you can help eliminate if it is the cord or the connection on the machine. If it is the cord, just buy a new one. You could try it in anything as an extension to see if it is the cord. Also, do you have to pulled at a sharp angle at either end? If so that can break down the wires inside.

I will take a look at that. Thank you!

Hello @Jeremy318 - I’m sorry to hear you’re having trouble.

As others have suggested a great first step here would be trying a different power cord if you have one available, or seeing how this cord behaves with a separate device. If the issue is the cord we can get that replaced no problem!

Thank you for reaching out. I will take a look at things and let you know if it’s the cord.

Which end of the cord are you wiggling? If it’s the end st the receptacle you may just have a bad/loose receptacle. I’ve had to replace just about all of them in my house because a phone charger wouldn’t even stay in.

1 Like

I have replaced the power cord and still seem to have the same issue.

Thank you for trying that. If the issue is still ongoing in a different outlet and with this new cord, our best steps is going to be to go ahead and get a replacement printer sent your way. I’ve just sent along an email with some further details to help get that process started.

I’ll go ahead and close this topic so we can finish up via email!