Premium splash screen won't go away


I am trying to learn how to use the glowforge but not buy the premium (yet).

For the life of me I can’t get the “welcome to glowforge premium” splash page to go away.

Heck, I can even see behind the screen my print job, but there’s no X, no optout.

Quite frankly it’s making me crazy. I JUST WANT TO START A JOB.


Enable cookies.

cookies are enabled. it makes no difference upon reload.

how do I make the splash screen go away in the first place? is there a hidden “x” or something?

This is with chrome and firefox


There is an X or similar but I can’t replicate it as it’s been so long since I skipped that.

I just know when I used to test using other browsers or on a tablet or similar, it would re-appear - just once as long as cookies were enabled.

Try re-sizing the screen so you can see any ‘accept’ or X button?

1 Like

resizing the screen changes nothing. there are only two clickable links: “get started” and “see all premium features”. also the borders of the splash page are all within about an inch to the browser window boundaries, so I know it’s showing its entirety.

Click either button and you should be able to dismiss from there.


I also don’t see anything via the chrome dev tools.

Ah: I clicked “get started” and something changed. unlike the first time I clicked it. it switched to a different splash page, that did allow me to click an X

file this under “definition of insanity” and thank you for helping me.



Glad it worked!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.