Preparing your design...and then nothing

I’ve been attempting to print a job that is somewhat engraving intensive. I keep receiving the “preparing your design” screen, which stays active for 5-7 minutes and then just disappears. If I press “print” again, the same thing happens. Can someone please look into this?

Usually a sign that there is something going on with the file…if you want to zip it and upload it here someone can take a look at it.

What design program are you using?

I have successfully printed it before - although that time I only printed one copy. This time, I’m trying to print six copies. It’s the Marvel calendar you’ve probably seen on here - I downloaded it from the Free Design section.

Is it vector or raster?

That file is very complex in vector form, and tends to overload the buffer. Rasterize it, and try to limit the number of copies you make…there’s a three and a half hour time limit on jobs.

The other thing you want to watch is the LPI that you are using - for full bed, you’ll want to keep it at 225 or 195. If you go with three copies at one time instead of six, you can probably go with a higher LPI.


It’s an .SVG. I have it the LPI set to SD, rather than HD. Still no luck. I have resorted to printing them one at a time (I’ve resized the image to ~5 in diameter - I’m trying to print glass coasters). Jules, I very much appreciate you suggesting the work arounds, although I believe this is still an issue that Glowforge needs to address. I’ve read of many others having the same problems for a long while now. BTW each coaster takes 18 minutes to print, so even printing 6, I’m well under the 3.5 hour time limit.

Edit: as (bad) luck would have it, once I got the single coaster to print, my dog pulled the exhaust hose off the back so I had to shut it down. Sigh.

There are other issues at play besides the time limit here…they have to do with whether or not the file is coded as a vector, with vector engraves, or a raster, with back and forth “fire and don’t fire” engraves.

The first requires much more code be written to the file, which can hang up in the buffer. The second requires less code, so the chances of the whole file loading are a whole lot better.

Eventually they will likely increase the size of the buffer. For now, processing them singly should work as well.


This is helpful. Although I’m a complete novice, I will try to convert this into a raster file and see if I’m more successful…thank you for the suggestion.

Thanks for letting us know. I’ve passed the details of your report on to the team and we’re looking into it now. In the meantime, I pulled the logs from your Glowforge and I can see you’ve since been able to engrave this design successfully. Did the tips @Jules gave work out for you, or are you still running into any trouble with this?

Hi Vee - I’ve been able to print it one at a time, but when I try to print 2 or more copies, I run into the same error.

Thanks for following up with those details. I apologize for the inconvenience. It looks like the issue you’re seeing is caused by a problem with our software in handling very large engraves. Your report will help us improve our software for everyone.

When we say your engrave is large - we really mean that it will take a long time to print. When your Glowforge prints an engrave, the head moves back and forth, line by line, like a inkjet printer. If the design is physically large or if you set your print to have a high LPI, the print will take longer, because the head needs to move further to finish the print. I don’t have exact numbers on size or print time for you, but I hope that helps a little. I suggest altering your print to make it shorter, like reducing the number of items you are printing at a time, for example.

I’m going to close this thread, but if you run into any other trouble, please start a new topic or email us at