Pressure Building...Temperature Rising


#1

Okay, it finally happened. I have a file that will not load. I’ve been trying all day. It’s for a fundraiser at our local elementary, it’s the item being donated by the 3rd grade (my wife’s team). I have tried this file every way to Sunday, but I can’t get it to load. Knew there were some problems with embedded bitmaps in SVGs, so when the original wouldn’t work, I removed the bitmap and added it separately. I realized I might be bumping up against the size limits (getting close to the hard limits for engraves. Nothing seems to make a difference. If anyone is feeling generous I would love to get a different pair of eyes on this. Here are all my different files:


#2

Could you put all 3 files in a zip? The first one is opening in Inkscape as a giant black rectangle (looks the same on the forum).


#3

Okay, one thing I want to point out is those chalk-like fonts have a tremendous amount of a data points associated with them compared to smooth fonts.

I’m going to look at them more closely, but I’ll bet that’s one of the holdups. (Might be better to rasterize that text.)

I’ll see what happens when I try to load it.


#4

What I would do on this, @kennethclapp, is go ahead and rasterize those fonts rather than just creating outline. Only one I looked at was the “All is calm, all is bright” but those types of fonts are pretty taxing on the processing side.


#5

Try this:

I ran the paths through the Simplify command to take out some of the extra points. Also, your bounding box was a black fill instead of an outline so I fixed that too. Probably should have changed it to a different color as well.

It loaded fairly quickly in the GFUI.


#6

Definitely pushing the size limit here.

Black rectangle is an object you can click on in Inkscape and delete. Not sure what it is an artifact of.

The “All is Calm” SVG is a true svg and it has many, many nodes. We have encountered fonts like this that translate into too many nodes or something. You might try to export that layer as a bitmap.

That size of the holly bitmap it somewhat large. Not sure if its resolution is such that it is causing failure.

Were you ever able to load just the holly border art and process that at one time? I understand that might create problems with alignment. But you could embed each bitmap where you want on an a 20x12 artboard SVG. Load it, print it. Then load the next bitmap in from a separate SVG with the other embeded bitmap in the same place.


#7

Slightly different approach - wasn’t sure if you wanted that rectangle filled in since it had no stroke, and I didn’t have to simplify the font…what I did was just split it into two different engraves - you can take it in steps and it’s not too much data.


#8

Okay, the black rectangle, on my computer, is a rectangle without a fill (was going to use that as a cut line.) I can get the text and little circles to load, but not with the holly wreath. That’s the problem. Think I will just replace that graphic and see what happens. Thank you guys for all the help.

I’ve actually been able to get that working both ways, as an svg, and rasterized. Maybe the problem is the text with the png of the wreath is pushing it over the size limit.

and just an interesting side note. On my computer that black box renders as a rectangle with a stroke and no fill both in AI and in the glowforge UI…wierd…


#9

Can you upload the holly separately at least yet and print that? If the whole design is in the center you can eyeball it and hope for the best. If you print that first. Then back out and come back in with just the svg with a few fiducials for a test score, you could do it.


#10

Okay…I just broke up the jpeg using the technique from this tutorial:

Worked really well on that image - I just split it into four parts. And it loads without trouble - just process one engrave at a time, and you might need to reduce the LPI to something a lot lower than 450. (I use 195.)

The vertical panels take a while to process, so give them time.

Calm Bright.zip (762.5 KB)


#11

Discourse strips out embedded style sheets for security reasons. If you set styling to Presentation Attributes, that won’t happen.