Print Stopped - unable to complete the print, fan(s) or?

A couple of times in the past week I’ve seen the “Print Stopped” when I press the Print button in the dashboard. The design appears to download before the message appears. The button is dark when this occurs, there’s no color code (that I have seen).

Today it’s doing it every time, having started at 5:36 (AZ time, mountain).
I searched the boards and found out it may be a cluttered fan grate, so I pulled the hose and hoo boy. It wasn’t entirely clogged but it was well on its way. I have cleaned it out and vacuumed the exhaust grate a bit, and restarted and am about to attempt another print.
I should probably try the degreaser, I’ve had the unit over two years (light use) and never even thought that something in there could be collecting cat hair.

Anyway, the lack of a temperature warning made me wonder if the issue is something else.
When the forge works, it works just fine, the hardware seems okay.

Can support tell me if I’m on the right track here?

EDIT: After a restarted none of the prints reach the start step. It will scan and focus, then the dashboard shows the Print Stopped message.


This just started happening to me tonight on every file, after multiple reboots and following several other troubleshooting steps found on the forums. It first happening around 6:30pm Pacific Time, the first time I tried to print today. Nothing else to add except that I’m having the same issue.

Mine fails before it even tries to print. Maybe this is a software / cloud issue?

1 Like

We have been having the same issue here.

1 Like

Mine too.

1 Like

The same thing is happening to us, we’ve restarted our router etc and nothing is wanting to print.

1 Like

Add me to the list of the users with the same issue

1 Like

I got it working by switching my browser.

It was not working in Firefox 78.0.1 (64-bit)

It did work in Chrome 83.0.4103.116 (Official Build) (64-bit)

On a related note, the scroll wheel function has been broken in Firefox for a few weeks in the Glowforge UI, but I notice it’s working in Chrome. I would guess that Glowforge doesn’t test the UI in Firefox.

1 Like

Ah, I didn’t even think to try a different browser, which should have been an obvious variable.
I probably didn’t think of it because I’ve been working in Firefox since the start and there’s never been an issue. I too see that I’m on 78.0.1 by the way.

I’ll definitely fire up the forge tomorrow and try it with Chrome. Fingers crossed it’s just a software issue. Many thanks for reporting your results!

1 Like

Many thanks for reporting your results!

Just doing my duty as an internet citizen. Thanks for the initial report!

1 Like

@smshaw Thanks for the heads up…Mine worked in Chrome as well!


That’s not how it works.

Support will only work with one user per ticket. If you want support assistance, you need to start your own discussion.

It’s fine to provide suggestions to help the original poster.

1 Like

I think they were just corroborating the story, and I found it helpful. No need to be condescending.

The fact that several people posted because they started experiencing the issue at the same time made me more confident it was a software issue, which led to me testing it in Chrome and helping everyone find a workaround faster.

1 Like

I’m so sorry that you’ve hit a snag.

Our team has identified an issue with our software that has caused some prints to fail. This has now been corrected. Could you please try your print again and let us know if you are still experiencing problems?

I’ve confirmed I can print in Firefox (78.0.1) again.
And did a test print in Chrome (83.0.4103.116) which works as well.
So glowface appears to be back in action.

Thanks to all who helped with this issue.

I’m aware that this is not a ticket for mine. I was just adding that I had the same issue. I opened my own ticket and they responded to my ticket in much the same way.

Thank you for your help confirming that all is well. Since this is now resolved, I’m going to close this post.