Pro Passthrough Release

@shop uses pdf all the time, maybe he has an idea here?

OK thanks. I’ve missed that detail re the AI-PDF.

Here’s one example of the scaling issue, don’t know if it’s current or the final solution. I don’t use AI. They say to use “save as” vs. “export”…

it’s not AI/PDF that has a scaling issue, it’s AI/SVG. PDF has absolute scaling built-in, SVG needs a DPI setting.

also, with AI you can literally copy/paste w/o having to create an intervening file.


I wasn’t the one with the problem, I don’t use AI, but they said they had issues with scaling in SVG which is why they had to use PDF. I just told them it was a known issue with a workaround, to the best of my knowledge.

1 Like

It’s called “outline stroke”. (Object/path/outline stroke)

As @shop mentioned you can actually skip all the SVG and PDF issues since you’re using AI. Just copy/paste artwork from AI into the GF dashboard screen using keyboard commands. There are no sizing issues this way.


The GFUI has to interpret what you want it to do with complex vector images, and if you have clip paths, overlapping paths, or open paths anywhere in the design it’s going to throw an error. The program can’t read what the intent is.

Your file has both overlapping paths and open paths…I’m not sure if you can see it in this closeup, but look at the blue outlines:

You can make that work by closing the shapes, then filling the shapes and creating a joined Compound Path in order for the GFUI to be able to interpret it…BUT, by far the easiest way to deal with a complex vector engrave is to rasterize it before you send it to the GFUI. That way you get to make it do whatever you intended. It generally does not add error to the raster image, and the GFUI is going to rasterize vector engraves once it gets them anyway.

It’s just the fewest number of steps to fix the problem.


Agreed on the raster. Does take longer to run, but fewer errors.
It’s possible that some of my issues with this print process (not b/c of it being vector or raster) has to do with my Glowforge. Just sent it back to HQ for some (unidentified as yet) repairs.

Jules I did my first print on the pass through but for some reason the system would not recognize the approve material and even though I kept putting the material somehow it still did not cut all the way. Do you h e any recommendations or is my Beta software not working. I sent a message to support however they said to log on to this feed to see if I find someone with same issues :confused: was so excited to do my 1st big pri t and got super stress

It’s probably a good idea to get some cardboard to test your first prints on…it can be expensive to run tests on the large sheet proofgrade. (You are going to mess up at least a couple dozen prints learning how to use it…guaranteed.)

If it is not cutting all the way through, you might have to make adjustments to your settings…slow the speed down by about 10 points…because we don’t get a second chance with this. Using the passthrough is an Advanced function. Run some tests on the wood first, in a corner somewhere, and make sure the beam always cuts through the material. (I automatically slow the speed down by 10 points to be safe.)


First: This one is critically important - start the print with the material pressed flush against the left lip of the tray, and keep it tight against the left lip during each transfer. If you are working on something that is skinny, you can use a spacer bar against the left lip to bring the material out into printing range. But do not start with the material against the right lip of the tray. Place your design against the left edge also. The mechanics of the way the system works and what the camera can see in each stage, can make it fail in the final stages if you have the material too far over to the right, and the design runs too close to the right edge.

Second: Make sure the material is pinned down flat at all times. Use the Honeycomb Pins not magnets.

Third: Be sure the weight of the material is supported both in front of the machine and behind the machine. Once partial cuts are in place, the weight of the material hanging down will cause parts to pop up in the bed, and can cause shadows that will confuse the camera. (In addition to ruining some of the work if you are going for a complex design with multiple operations.)

Fourth: The way that the alignment works is that the camera is matching before and after pictures…sometimes you have to leave center cutouts in place near the match point in order for the camera to recognize the match point. Easiest way to do this is to just remove interior cuts below about an inch or two underneath the match point, but then tape the ones near the match point with a strip of clear tape before shifting the section, so they don’t get hung up while shifting the material.

Those are the most common causes of alignment matching failure, so if any of those are applicable, make some adjustments to the way you’re doing it and see if it helps.

The most common cause of flat out “fail-to-print” errors are file errors. Get into the habit of testing them once on cardboard if you’ve never run that particular file before.

Passthrough cuts require a lot of user interaction and thought up front, but they are tremendous time savers overall. You just need to get familiar with the process. :slightly_smiling_face:

I have the Pro - using the beta passthrough (not for the first time) and trying to cut through PG draftboard. I have cleaned the machine, and it cuts perfectly when I am not using the passthrough. My material is flat, but it looks as if the machine isn’t focusing correctly as the lines are thicker and charred. I’ve checked to see if the lens is loose, it’s not. I’ve read through the tutorial multiple times and that did not resolve the issue either. I can’t think of anything else to try. Please help! :slight_smile:

Last cut attempt was 8/31/2020 at 8:03 pm

1 Like

Okay try setting up a Custom setting and using these numbers for Cut through on the Medium thickness material : 165/Full/Focal point 0.14

Make sure the material is pinned down flat with honeycomb pins…do not rely on “it looks flat”. You have to pin it down.

And watch it while it cuts. If it looks like it is flaming up too much you might have a different problem.

There have been instances where prints have behaved differently when using passthrough.

If you note the date/time of the print, they can check the logs to see what settings were actually being sent down to the machine during your print.

Thanks! Ok, tried that. Still didn’t cut through and no flame ups.

How thick is the material? Do you have a set of calipers? Take a few measurements and see if it has gotten swollen from humidity. That setting should get you through the Medium draftboard, it’s slower than the default.

My calipers say about .133 - .137

That might explain part of the problem…the material defaults are set for 0.125" thick.

You can try slowing it down a little bit more, but those settings I gave you should be getting pretty close to getting through material that is in the 0.134" range. Maybe try 5 points slower on the speed.

Did you get the email on the settings tuning that was sent out to affected users? If so, you’ll need to wait anyway…I don’t think they have rolled it out yet. (After Sept 2nd.)

It will cut on the first pass but not on second or third passthrough. It looks by the thickness of the lines that it’s engraving not cutting. I have cleaned lenses but I only have this problem on passthrough mode.

looks like yet another change in focus or power issue. This bug/issue keeps popping up.

1 Like

The thing is… a focus change is a very deliberate action - and there’s no reason for it between steps in a passthrough print.

The lens is pretty much “locked” in position unless there is a commanded change, and it takes a few seconds to change it.

1 Like