Problem completing address form in "Do you want your Glowforge now?" link


#1

I’ve sent an email to support that says:

Hey!

I just got my PRO “Would you like your Glowforge now” email and the link sends me to this weirdly formatted form to collect your address. No matter what I put in, it returns me to the blank form with just my name. I’ve tried 3 different browsers and all look the same.

Anyone else?

This is for a Glowforge Pro. The form has tiny text files for State and country, and State is followed by “Select…” as though it should be a dropdown, but is then followed by a one character text box. “Country
United States” is followed by a line character text box.

Oh, and the Glowforge logo is huge!

All very interesting, but I’d really like to complete the form.

Thanks!

Keith


#2

Bummer. Hope it resolves quickly.


#3

I suggest trying a different web browser if you want to give something a go before Glowforge responds.


#4

it looks like its not loading all of the css/javascript necessary for the page to work. their security certificate might be having a problem, or the cdn theyre hosting that stuff at might be down temporarily, or you might have just thrown a js error that stopped all other execution on the page.

in chrome try hitting f12 (alt-cmd-i on mac) to open the console up and see if it shows any errors


#5

Hi @keith2!

Thanks for letting us know. We need a bit more information to investigate. Please do the following:

  1. Go to https://www.whatismybrowser.com/
  2. Click the button that says “Link”
  3. Copy the highlighted link
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you. If you would prefer to provide this information via email, feel free to reply there.


#6

For Safari: whatismybrowser.com/w/R8KSMCK
Firefox: whatismybrowser.com/w/HC244YG
Chrome: whatismybrowser.com/w/D7ZH8QR

All give the same result…


#7

Looks like a certificate problem. Console:


#8

:wink:


#9

Check your date and time on your device too!


#10

Yes, this could fix your certificate issue.


#11

NTP all good on this MAC. But I could try from another machine…
Only me??? Weird.


#12

Keychain Access, check the “Trust” for the glowforge Certs.


#13

Thank you so much for the details. I’m investigating it now. As soon as I have more information I’ll update this thread.


#14

Well, it’s a mystery why the certificates were not valid on my laptop, but I woke up this morning early and tried my iPhone browser and the pages loaded (and loaded, and loaded…) and there was no problem getting my Pro acknowledged. So… Modern weirdness, I guess.

Reload, reboot, try a different machine.

Thanks for all the fish.

K


#15