Problem with Pixelmator Pro Exporting SVG

I use Pixelmator Pro. When I export a simple rectangle of a certain height and width to .svg, then open it in Glowforge, the size of the rectangle in Glowforge is too large and I have to resize it. For example, if I export a simple rounded rectangle .svg file of size 1.68" wide x 5.13" high, it shows up in my Glowforge as 5.25" wide x 16.031" high. Am I missing something here? I asked Glowforge Tech support and they fell back on the “we are not familiar with Pixelmator - it must be their problem” answer. Pixelmator is a pretty popular program and in every other respect is perfect for GlowForge. There MUST be other users out there who have run across this? Has anyone got a solution?

Here’s a hint: both Pixelmator values seem to be multiplied by PI (3.125). But is Pixelmator doing this during export, or is Glowforge doing this on import?

I have never heard of Pixelmator, so pardon my ignorance. Is there a preference setting in the program that includes dpi? Can you save as pdf rather than svg. since pdf files maintain their size?


Interesting thought, since .PDF files are supposed to be able to store vector data (I’m cutting out this rectangle so I need vector data).

I tried exporting my rectangle to a PDF and importing it to Glowforge. The result was disappointing. Although the SIZE was close to correct, the Glowforge would only allow me to ENGRAVE not cut. So I assume the vector data was lost somehow.

1 Like

I have Pixelmator but never use it with the Glowforge. I use Affinity Designer. That being said though, is it possible to set up an ‘artboard’ in Pixelmator? If you can set one up in a 20"W x 12"H format, everything should load into the UI at the correct size. Also, the dpi number is important.

I know they’re not the same programs, but this is what my settings look like for the preset I use all the time…maybe it will give a bit of insight. Good luck to you!


This happens with many programs.
I’ve gotten into the habit of putting a box of known size around everything in a different color (like 12x20) Then once imported I check the box size in the GFUI (ruler icon), if it’s wrong you can select all and resize everything together to the known box size then delete or ignore the box.


Valid SVG files have precise dimensions in the document itself, and the Glowforge UI does not interfere with that. If a document is not opening as expected, the problem is in the file or the application that created it.

Can’t help with your app specifically, never heard of it, but if you post your file here, any number of people can check using a real design app. Sounds like it’s just not exporting correctly…

1 Like

Yes, the secret is DPI (dots per inch). The must match what the GlowForge is assuming which seems to be 96dpi (I dont see a way to set this anywhere).

WHen I export my rectangle .svg at 96dpi, GlowForge imports very close to the correct size.

Mystery solved. Shame on you Glowforge. You should have known this when I asked tech support.

The reason it’s only close and not exact is that the :glowforge: doesn’t have a set DPI (which is why tech support didn’t tell you a DPI) - it’ll do whatever is in your file. It’s up to your drawing program.

Seriously - the 20x12 drawing area, bed, frame, whatever Pixelmator calls it will mean that the dimension are exact no matter what you set the DPI to!


They can. But in practice 99% of SVGs use pixel dimensions, not real-world units. (Which makes sense; SVG is mostly targeted at on-screen use, primarily on the web.)

To convert pixel units to real units you need the conversion ratio, usually expressed as “dots per inch” or DPI. This used to vary widely, with some programs defaulting to 72, others using 90 or 100 or 110.

But at some point a few years ago most SVG-based software started to converge on 96 DPI as a default. (Mostly because web browsers always assume 96 DPI, because of how CSS defines pixel units.) So for best interoperability one should always export SVGs at 96 DPI.

Alternatively, one can use PDF as that format always uses real-world units.

And on the Glowforge there’s a third option: always make your file exactly 20 inches wide and 12 inches tall. When the Glowforge software imports a file with that 5:3 aspect ratio it ignores its usual assumptions about DPI and scales the file as needed to make it 20×12. (Or at least it has in the past; I haven’t tested this recently.)


Yup, this still works :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.