Referral Page


#1

500 error on referral page. The referral page on the glowforge website is down. Has been for about a week now.


Broken Referral Page
#2

Works for me.


#3

URLs from both of you?


#4

this works fine for me: https://glowforge.com/referrals


#5

Same for me.


#6

https://glowforge.com/referrals

I get this from both mobile and pc. Maybe just my account?


#7

Must be. I clicked on the link you posted and it worked.


#8

Broken for me, too.


#9

This seems to be fairly common – I’ve seen several times where people report 500 errors but it works for someone else.

Sharding data is good. Also good: monitoring.


#10

Just checked mine for the first time to work out how to use it !
Seems to work for me OK.
John :upside_down_face:


#11

So we’re the only broken ones?


#12

that’s really weird. it works for me in chrome. are you using a different browser maybe?


#13

Safari on my phone and chrome on my pc. Internet explorer at work. All 3 don’t work for me.


#14

have you tried clearing cookies/temp files?

it’s just odd that it works for some people and not others. i’m getting it just fine from home and work on chrome and on my phone/safari.


#15

Yep. Just tried that and tried logging on to it from my kids computer. Still 500 error. Besides, a 500 error is an issue on the server side. Can’t be on my side.


#16

it’s just odd that some people are getting server errors and others aren’t. a 500 error is a very vague server error, so i guess it’s possible the server is returning an error from data it received from you. which is why i suggested cookies/temp files.


#17

So this happened to glowforge before if you peruse the forums. Same as before. Some people are effected and others not so much. I originally put this in the support section but somehow it moved here. I guess they don’t see this as an issue?


#18

If support moves something they usually add a post to the topic explaining why they moved it. Someone else may have moved it, in my opinion incorrectly.


#19

I’m getting it on my Mac (Chrome) and my iPhone. As @joshnmary484 said, it’s a server side error; cookies, etc. aren’t relevant.

I had this same problem before with the purchase history page, but they got that one working for me.

Could someone with the ability to move topics please put this BACK in Problems and Support?


#20

I suspect something quirky with 1 of the servers providing glowforge.com my system is working and using 54.209.18.85
On the other hand something could be messed up in your account records for just the few of you. Maybe someone should post in problems and support and point them back over here?