Refresh Bed Image


#1

Every time after I open and close my GF door to put in a material or reposition the machine scans to display the bed image and it flashes the bed image for just a split second. I then have to hit refresh bed image and wait again for the scan process and most often the image then stays displayed after that scan.
Any ideas why this is happening?


#2

Which browser, device type and OS are you accessing the GFUI?


#3

Safari on macbook pro and yes to the GFUI.


#4

Don’t have my Mac Mini up, but do you have either Firefox or Chrome on your Mac?

Do you see that same behavior in either of those browsers?

Trying to narrow down whether it is browser specific or how the hardware is communicating over the internet.


#5

Thanks.
I’ll get Chrome and try it. I don’t have the fastest internet connection, so maybe that’s it. Also, no one else seems to be reporting this problem, so probably my connection.


#6

I believe there are known issues with Safari, so I think @PFI-Guy is on the right track.


#7

So @PFI-Guy and @cynd11 are correct that there are multiple mostly-small issues with Safari. But I’m curious… You say you don’t have the fastest connection. If you don’t refresh the bed image manually, and just wait a minute, does it ever auto-refresh (like it’s supposed to)?


#8

I have waited for several minutes and it doesn’t refresh. It always refreshes the second time after the scan.


#9

Okay. In that case, let Chrome be your friend. Chrome and I go back years and has always treated me well. :slight_smile:

Do let us know your Chrome results, please!


#10

Chrome solved it. Thank you all.


#11

Since you have a ticket/bug report in, maybe you can go to:

And paste the results URL back they give you so they will have all of the technical details to go along with the report :slight_smile:


#12

Glad you’re running without issue!
I’m sure they’ll eventually fix all of the issues they have with Safari.


#13

au contraire, my friend. I had the exact same problem…as well as issues zooming in to see my files on the bed. I still use Safari for regular browsing, but set Chrome up to go directly to the Glowforge UI and I use it for nothing else. I put the Chrome alias in my dock and renamed it ‘App Glowforge’ so I can get there in one click.

16 PM

Have had no problems since. Give it try. Wishing you good luck.

edit; I see now that you’ve resolved it. Great!


#14

Glad to hear that Chrome fixed it for you.

Our team is investigating this issue with Safari. In the meantime, we suggest you use another one of our supported browsers. I’m so sorry for the inconvenience.


#15