Refurbished machine stuck on homing

I received a refurbished GF (had to send my printer back under warranty as it had a problem with cutting) and now this new GF I received today is stuck on homing . On the app screen, the old/last image I tried to cut on the other printer is still showing up. I’ve read some other support info and have tried everything suggested, and it’s still not working. Any suggestions would be appreciated! I feel like it’s something so simple that I’m missing. I almost get the impression that it’s not reading anything (have cleaned all lenses)
Many thanks

Perhaps it’s trying to connect to the one you sent back?


This new one connected to the wifi signal it provides during setup. I even tried it a few times to make sure.

And on your dash board you have that machine selected?


Just double checked, and yes I do.

1 Like

So when you turn the machine on, what happens?

1 Like

Oh blimey I may have just figured it out! When you asked if I had the machine selected, I thought yes. I have 2 options one being Glowforge which says Homing beside it. The other is the WRQ-382. So I switched it to the WRQ and it seems to be working. Thank a million! I just assumed it would be glowforge and didn’t even think to look at the drop down menu to see my other options. Really appreciate your help!


My name is Mercedes and I’m part of the Technical team here at Glowforge.

@breannacoxon it looks like @beerfaced helped you out a ton here! I’m glad you are back up and running. It looks like you have another ticket open for a different issue, so I’m going to go ahead and close this forum post now. If you have any other questions or need help with anything else feel free to send a message our way by either creating an email ticket or a new forum post!