Rendering your design issues

I am trying to upload a photo to engrave, but it just sits on rendering. it 1.8MB either as a pdf or jpeg. how long should this take to render? I can successfully load other projects of a smaller size, including similar pictures in lesser MB size (in the KB size), catalog files, etc. How long should it take to render?

I have cleared cache quit safari, restarted several time.
Freddie.pdf (1.7 MB)

here are the files, if someone wants to see if they load ok on their machine. TIA


I’ve been having the exact same problem all day. If the design has an image, I can’t render it. Even designs I had already uploaded and used will not render.

Went and gave it a try for you. Rendering took about 7 seconds and processing took 11.

I used Google Chrome on Windows.


It rendered ok for me.


In don’t have any helpful tips but Freddie is freaking adorable.

1 Like

Seeing these replies, I downloaded the file and 5 min later it’s still not rendered. 24 hours without my account working. I’ll be contacting Glowforge support.

Such a cute dog!!!

I just tried it on my iPad using chrome and it loaded immediately. Not sure what’s going on with my iMac. Will try it there; it may have just been my account, having read some of the replies. Thank you all for checking it out for me.

@ekla @rvogt she was a great dog; she passed away about 3 weeks ago, hence my desire to memorialize her. You never know how good they really are until they’re gone.


Same issue. Small keychain with image, something I’ve printed at least 50 times in the past, stuck on rendering for about 15 minutes before it times out. Chrome and Windows. I’ve cleared my cache, restarted computer, restarted wi-fi, restarted Glowforge. At that point it allowed me to print one at a time, but I can’t print multiples (copy paste within the browser) even when I change the initial artwork to have multiple iterations. If you get an answer from support, please post here.


My name is Mercedes and I’m part of the Technical team here at Glowforge and I’ll be helping you troubleshoot today.

It looks like the good folks on the forum were able to help you solve this pretty quickly. I was also able to upload the photo on my end with no problems.

Were you able to get it uploaded and printed alright in the end?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.