Scale window disappeared

The scale (ruler) icon/settings have disappeared from my GF app. This is crutial to my orders. Where did it go?? I tried refreshing the page and even logging out and in.

Try Chrome for your browser.

This worked, but why did it stop working in FF? Ive been using FF for months.
I dont think FF has even has updated.
I dont use chrome anymore it is a memory hog, not to mention data stealer

The new Microsoft edge browser is decent, I’ve been using it much more than chrome because of the resource hog that chrome is.

The good news is all functions in the interface remain. Try going back to Firefox and see if it works again. Many people use Firefox without issue, so there could have just been a glitch in the matrix earlier.

Still not showing up for me.

Same for me, but with they are all gone in Chrome. The precision placement icon/window and premium tools are all missing.

They show up in Safari.

I’m sorry that you’ve run into trouble and the scale window isn’t appearing. Thank you for letting us know; our team is looking into this. Do you have an ad-blocker or similar plugin installed for your browser? If so, will you please temporarily disable the plugin and let us know if the scale window still isn’t displaying?

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email