Scanning/Centering Temp Fix

Not sure how many are affected by the centering/scanning issue right now or will be in the future, but as some of you know, the fix is getting a new black ribbon cable that is attached to the lid. I’m currently waiting for a new cable for my own, but I’ve found a workaround in the meantime. I can get my machine to do it’s regular setup as long as I’m not signed in to the app.glowforge site when I turn the machine on.

After it finishes the startup process, I sign back in, upload my design, and can do that single job. Then I have to sign out of the website, turn the machine off, then back on, and it will go through the startup process like normal. Most importantly, I am not signed in until the machine has finished it’s startup. Rinse and repeat.

Not sure if this will help anyone else, but I’ve successfully done at least 5 or 6 prints with this method and it’s worked every time since following these steps. I’ve uploaded these pics to show the time stamp difference. The first one was stuck scanning for a little bit, did the above steps and was back in business with the second pic.

5 Likes

That doesn’t sound like a black ribbon cable issue to me. A hardware problem wouldn’t be affected by whether you’re signed in or not, etc.

5 Likes

You’re telling me. This is why I had posted in the P&S saying mine seems different than normal. It would be cool if anyone else with similar issues could confirm my process works for them or not, really if several people could confirm or deny it so we can see what’s going on.

But hey, it’s Glowforge’s world, I’m just living in it. They’ve already replied to my email with this line:

I suppose after the cable gets here I can see if it fixes it for good or not, that would also help with my analysis of the situation.

3 Likes

Glad you have a work around for now & shared it–“intermittent” is the worse type of issue to diagnose (in any product/application). Does makes sense if the wires within the cable are just starting to crack that sometimes connection OK, next time they’re flexed not the case… Hope indeed the new cable gets you back to normal!

1 Like

It’s not intermittent in the sense that it will continually scan forever unless I turn it off and on. I just can’t figure out why not being logged in during the startup lets me get out the one print. Even if I sign out after starting a job, but still while the laser is going, it will hit the Scanning message after finishing with that job. The same goes for when I’m signed in and turn it on, but instead of scanning, it’s Centering endlessly without doing anything.

I don’t even have to open the lid for these messages to happen. My thoughts as to why this could be the case, is that maybe there’s a short that’s only spotted during the second phase of scanning, like, perhaps maybe the Glowforge sends a similar but different set of commands to capture the image while we’re signed in, versus while we’re signed out, and it’s in those commands that the short is being caught.

Are you actually hitting the “log out” option, then going thru the signin process where you have to enter your username and password, or just closing the browser window?

Yes, hitting the log out button. I’ve tried it on my computer in both Chrome and Edge, tried it on my phone, and just checked my iPad using Safari. All the same results.

1 Like

Well, this is weird.

I wonder if there’s a bug whereby the ui isn’t able to receive push status updates from the gf? Are you using any network modifiers like a pi hole? Any changes to your router?

Great theory, and if not for GF already mentioning that my logs indicating issues relating to the cable, this would seem the most likely candidate. The router hasn’t changed since I set it up, and I don’t run anything like a pi hole (wish I did some days for other reasons). I wouldn’t say any noticeable change has happened since I got this unit, other than chrome and it receiving the occasional updates.

The Chrome updates were suspect, which is why I tried on all my devices and the different browsers, but yeah, still stuck in this limped state. I can only wait and hope that the cable is the true culprit, because sending this guy in would be a real bummer.

So weird.

Extremely weird. I am glad you found a work around though.