Scanning your material -> Calibrating head. Ack! Tearing my hair out!


#1

This is turning into a major time-waster. About half the time I go to start an engrave job, I’m shown the “Scanning your material” or “Preparing your design” message, and then it all disappears and I’m back to “Calibrating the head of your Glowforge.” So there goes another 3-5 minutes. I can only assume that something doesn’t like the size/resolution/whatever of my file and is crashing, but…damn. Please fix! (OS/browser doesn’t seem to matter, but for what it’s worth, I’m mainly using Mac OS [Low] Sierra with either Safari 11.1 or 59.0.2.)

The workaround is usually to just keep trying, and after three or four CTHOYGFSOD’s (Calibrating The Head Of Your GlowForge Screens Of Death), it will start the engrave.

EDIT: My current design just won’t print. Umpteen tries, and it goes: Scanning -> Preparing -> (window disappears) -> Offline -> Calibrating. I’ve laid out a tiled pattern of rather sizeable (3000x2000 pixel) grayscale PNG images, however… all but one of these is set to Ignore. If I can’t engrave a single image of that resolution without crashing the thing, I’m in trouble. If somebody from Glowforge could have a look and see what’s up, I’d be much obliged. Thanks!

EDIT #2: Removed all of the “Ignore” PNG images from the design. To no avail. :frowning:

EDIT #3: I should mention that I have several times switched the 'Forge off and back on, and just tried going through Setup again, as suggested on another thread. Got stuck on the WiFi portion though; I kept getting the error about losing contact with the unit or getting an unexpected response. (101% certain I had the WiFi password correct, and switching the unit off and on again restored connectivity.)

EDIT #4: On what must have been the 40-somthingth try (I’m a masochist), it got past Preparing and let me do the engrave. I won’t declare myself unblocked, though, because 100:1, I’ll be right back at the same issue as soon as I un-ignore the next image.

Also, I hadn’t used my 'Forge in a couple of weeks, and since returning to it, I notice that the stepper motors are making all kinds of new, lower-pitched tones. They seem perky and high-pitched when the unit is first switched on, but after a print or two, they’re a few octaves lower. Probably unrelated, but seems worth mentioning.


#2

My guess is that the images that you’re trying to engrave are either creating an output wave form that is bigger than the buffer (>3.5 hours) or the server is timing out trying to compute the waveform (too many nodes). Both are intermittent about reporting the error for me. It often just gives up as you describe.

They should fix it to more consistently report the error, but that won’t help you as much as you might like because you’ll still be waiting 5 minutes for it.

The workaround for the first issue is to reduce the time to engrave by choosing a lower resolution or by slicing your image into pieces.

The workaround for the too many nodes problem is to convert the vectors to be engraved into raster images of sufficient resolution in the design software before upload.


#3

Yeah, an actionable error message would be a major improvement! I’ve gotten the “design too large” error before and had to split images. I feel like even this happens a bit more often than it should, but the uncontrolled failures (what I’m running into here) are definitely a bug. I’m really hoping that the error in this case isn’t from my design being too large, though. I’m doing a standard-def engrave of a 6 Megapixel grayscale bitmap. If the cloud and/or hardware buffers can’t handle that…that would be a very burdensome limitation.


#4

I was using my Glowforge about the time you were and didn’t have any issues at all with it, so this may not be a server or software error.


#5

It’s not so much the file size or pixel count but the actual engrave time. The buffer currently handles jobs up to about 3.5 hours in run time. Run time is dependent upon: total engrave area, speed, lines per inch.


#6

I see. Well, when I’ve managed to get these particular engraves to happen, they’re only taking 15-30 minutes. All standard-def, all in the neighborhood of 3000x2000 pixels, grayscale, scaled so that the largest dimension is in the neighborhood of five inches.

They come out looking pretty nice when I’m lucky enough to have them start. Mostly I just end up calibrating the head of my Glowforge a bunch of times. (It should be REALLY spot-on by now! ;-))


#7

So far this evening, my Glowforge is condescending to engrave on about one of every four attempts. (The other three attempts lead to Offline -> Calibrating.) I’m not doing anything between attempts except clicking “Print” again. :roll_eyes:

And as before, I find that there’s little consistency to the stepper motor drive speed anymore. One moment, it’ll be cranking at 1000+ pulses/sec like it used to, and the next moment (either after a print or after a calibration failure), it’ll move at some random neither-here-nor-there speed that produces a funny, low-pitched tone. I’m starting to wonder whether my 'Forge has dementia.


#8

I have had recalibration issues (which for me meant the zero point changed and the cut would not be where it was supposed to be.) One suggestion was issues with the internet provider, which is nothing you could do about except that it is very intermittent and not likely to continue day after day. I have never proved that was the case but the issue certainly is intermittent. For me anyway.


#9

That stepper motor sound makes me think of the stepper running close to limit. My 3D printers do that sometimes when they are getting a certain type of instruction. On my printers it means something is binding and the printer is attempting to correct and realign. I don’t know what it could be with the Glowforge.


#10

Yeah. The thing is, it only does these funny-sounding movements between prints, not during a print. During a print, it’s rock solid and sounds the same every time. But, for example, when a print finishes and the thing goes into cool-down mode, the speed with which the head is returned to the top-left position is totally random. And I know the speed ramps up and ramps down during these movements, so I’d understand if it only reached top cruising speed when it had a long way to move, but sometimes it’ll have to move from the bottom-right position all the way back to the top-left, and it’ll do so at what sounds like only about 100 pulses/sec or so–and it takes forever. And after the next print, it’ll move 10x as fast. Same thing during the Scanning Your Material phase. Sometimes the head whizzes around, and other times it moves with painful slowness. No obvious rhyme or reason.

As long as it’s not doing this during a print, though, I’m inclined to think it’s a software issue.


#11

I’m so sorry you’re having trouble. I extracted the logs to investigate the problem you reported, and they show that there are some connectivity issues. Thank you for sharing what troubleshooting you’ve done so far. I’d like to run through some more - I know you’ve done several of these already, but if you would please go through these that will put us on the best footing going forward.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

We’re not finished! If the trouble continues, could you please run one more test? This test requires a laptop or desktop computer. If possible, try these steps from a laptop computer placed on top of your Glowforge (and on the same Wi-Fi network) for the most accurate results.

  1. Run the test
  • Mac: Open Finder/Applications/Utilities/Terminal, then type the following command, and press the return key: ping -c 50 app.glowforge.com
  • Windows: Open the Windows Run dialog box by pressing the Windows key + R
    • In the dialog box, type “cmd”, then “Run” or “OK”
    • Type the following command, then press the return key: ping -n 50 app.glowforge.com
  1. Allow the test to finish. When it is complete you will see results under a “ping statistics” header.

  2. Take a screenshot of the results

  • Mac: Press Shift-Command-4 and click and drag a box around your image. You’ll find the screenshot file saved on your desktop.
  • Windows: Click on the Start Menu and type “snipping tool”. Open the Snipping Tool > New then click and drag a box around your image. Click the Save icon and name and save your file.
  1. Reply to this email with the following:
  • The file you saved in Step 3.
  • A description of what’s happening, what you’ve tried, and what results you’ve seen so far.

Please let us know if this helps the issue.


#12

Thanks, pip. I’m about to do another batch of these, so I’ll try your suggestions and report back. I’m hoping it’s not a signal strength issue, as my Mac is sitting only a few feet from my Glowforge and the WiFi strength is maxed. (Access point is on the floor above, though.) If I might jump ahead a little: Perhaps I might prioritize traffic on the ports used to communicate with the Glowforge. My router allows this sort of thing. May I know which ports are used? (I’m sure I could sniff this, but if it’s something you’re able to just tell me… :))


#13

Should be TCP 80 and 443. And UDP 123.

Not sure how your set up is but you could possibly just set the device priority to high or highest.


#14

It may very well work like that, now that you mention it. I haven’t fiddled with it for a while. Thanks!


#15

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.


#16