Select your Wi-Fi network from the list on the right

I get to the screen that says “Huzzah! Your computer is connected to your Glowforge.” and the screen to the right where I should be able to see a list of Wi-Fi networks is not showing anything. I tried plugging in join network but that brought me to a screen that doesn’t do or show anything. I tried checking for any popup blockers but I don’t have any. I even tried using Safari rather than Chrome. Don’t make me check internet explorer.

Welcome - sorry your first step isn’t going easily! Is it possible your router is transmitting at 5Ghz instead of 2.4Ghz? The :glowforge: only works at 2.4Ghz

1 Like

A minor correction, its 2.4 GHz there is not 2.5 GHz range for home wireless networking.


Is you router broadcasting its ID? Some stay in stealth and you have to put the id in. I would assume so, but one never knows what gets set up. Just guessing.

Have you tried it using a smartphone? That’s what I have done and I leave the computer on the

I’m so sorry you ran into trouble setting up your glowforge.

What @deirdrebeth & @icirellik suggested is a good first thing to check. Your Glowforge requires Wi-Fi using 2.4 GHz b/g/n and WPA2-PSK, WPA-PSK, WEP, or open security. Please double check to make sure your network meets these requirements.

It would also be worthwhile to check if your network has a captive portal. While Glowforge supports connections through open or unsecured networks, we do not support connections that require interaction with a landing or splash page, commonly known as captive portals. Captive portals usually require both a username and password to log in, and often will appear only on the initial connection, when a device is registered with the network. Occasionally these networks will require a terms of use or other type of agreement to be acknowledged before continuing.

The easiest way to confirm whether your network uses a captive portal is to try connecting with another device that hasn’t used the network before. Alternatively, if you’re able to contact the administrator of that network, they should be able to tell you.

Please let me know what you discover after checking the above and we’ll advise on next steps

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email