Server Error


#1

Just wanted to bring this to the attention of @GlowforgeStaff
Received this this morning when I clicked the :glowforge::

Clicking the :recycle: Try Again button worked fine.


#2

Yes I get similar errors from this forum about once a day on avarage. Always have done.


#3

You might want to include the URL from the link going to that error (if you clicked on a link from another page) and what the URL is for the page giving you that error.


#4

Just a heads up–I think they prefer you to send these sorts of things to support@glowforge.com rather than on the forum, as they are less likely to see and respond to it here.


#5

Let’s hope the GFUI resides on more-robust servers.


#6

they’re running it - or were - all on google’s cloud infrastructure as opposed to whatever servers discourse offers as part of their hosted offering.


#7

I didn’t realize Discourse was SaaS. Presumed they licensed for on-prem for some reason.


#8

it’s both but this installation is the hosted version. i think it’s free and this plus support is where the money comes from?


#9

Sorry. I didn’t word that correctly. I knew Discourse offered both SaaS and on-prem. I presumed, for some reason, that Glowforge went on-prem.


#10

Oops, I thought you got that error accessing the Glowforge shop. Different server. Disregard!


#11

ah. yeah. dan mentioned a little while back when i brought up a plugin.


#12

Yes, we pay the big bucks for the professionals at Discourse to manage this for us - unfortunately, with some loss of control and flexibility as a result (see the previous point about plugins being unavailable).

It’s actually better to post discourse issues here (vs emailing support) so the @discourse team can see them.

Thanks for the heads up about the problem!


#13

Hey there Glowforgers, I’m with Discourse support.

Looking into the errors, I can definitely see some bursts of errors that come through every now and then, based on this graph from Kibana:

(Times in UTC+1000, because Kibana tries to be clever and really isn’t)

The rate of errors wasn’t high enough to trip our “EVERYTHING IS ON FIRE!” error rate alerts, so we didn’t notice it proactively, but that’s more because there’s a lot of traffic for the errors to hide in than anything. We’ll have to tune those thresholds a bit.

The good news is, I’ve identified the cause of the bursty errors (there’s a restart process that happens now and then which isn’t as transparent as it should be). Slightly worse news is that it’s not going to be trivial to fix, but rest assured we’re on the case. Thanks for letting us know about it so we can get it fixed up.


#14

Thanks @mpalmer!


#15

Just wanted to let you know that we all appreciate your efforts.


#16

Can I bring up a different issue that popped up this morning for me? The keyboard loses input focus randomly (although it seems to happen when a discourse UI widget updates mostly, like when it saves this post while composing it!! ). It always happens when the ‘wait icon’ is displayed. I have to click the page to get focus back. Also yesterday I could click on a topic to bring it up and then use the ‘page up’ and ‘page down’ keyboard buttons immediately to navigate, but this morning I have to click on the page first. I’m using windows 10 with edge browser.


#17

@discourse


#18

Please create a new topic for this separate issue, preferably, since this isn’t a Glowforge-specific issue, on https://meta.discourse.org. Dropping all sorts of random issues into a single topic is a great way to make sure that nobody’s problem gets solved properly.


#19

Amen.


#20

I am unable to repro this issue on https://try.discourse.org can you reproduce it there? Do you have any plugins? Can you try disabling them?

If the issue is persistent there do you mind opening an issue on https://meta.discourse.org?