Settings Screen Problems

Within the last few days I’ve been having REALLY WEIRD setting screen issues. Whenever I try to adjust I just get a blank white box. I should be seeing the options to adjust my cut, score, engrave, etc… I have to keep clicking, and scrolling around. It’s wasting a lot of time. Anyone else having these issues?

1 Like

SAME ISSUE HERE… SO FRUSTRATING! Ready to dump this thing.

What browsers are you both using?

I’m also having this issue - and I’m wondering whether it might be connected to an iOS update. Did you both recently update the iOS?
I hope we get a fix. This is making some projects impossible for me! I can’t select what to ignore!

Yep - it’s Safari specific.
I tried Firefox and it’s working fine.

Whether it’s Safari specific or not, I think it’s a GF problem. I’ve always used Safari. Had no problems until my latest update. It’s like a GF patch update needs to happen to run with the new IOS.

Glowforge support is aware of this issue with the newest version of Safari. Until they come up with a fix, use a different browser.


I just saw that GF is aware.

I have been using Safari for nearly 3 years and have not had an issue.

1 Like

I am using Chrome with the same problem. Yesterday printed four objects, turned machine off, restarted and it no longer worked. App shows “Unexpected error” after 30 seconds and reboots.

This discussion is about a bug in which the popout settings panel appears blank in Safari.

You are not experiencing that problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.