Setup/1st cut/software issues

Completely new to this all! I’ve read more then I can even retain before I resorted to reaching out. I’ve finished the set up process and now for the first cut! Yet Glowforge app (software) will never make the “Print Button” available when trying to cut the Gift of Good Measure. It’s placed within the Cutting area, had to manually choose the proof grade material since it never rendered a view from the camera i only see a white Canvas. Ive reseted, rebooted, erased history/cookies and now it won’t render the Gift of Good Measure (Med Draft) design no more, only the metric version. So now im trying a honeycomb crumb tray pin i got from here for the 1st cut and no luck getting the software to allow me to print! I’ve turned off waited a while and turned the machine back on several times… I’m stuck! I’ve been at this for over 3hrs!

One of the things that can sometimes help is to reboot your devices in the correct order:

(A dropped signal will commonly cause the screen to lock up, but it’s pretty easy to clear.)

  • Turn off the machine. Turn off the computer. Unplug the router.
  • Wait a couple minutes.
  • Plug the router back in and let it fully start up.
  • Turn on the computer and let it fully start up.
  • Turn on the Glowforge and let it complete the startup calibration.
  • Then open the and check the status for “Ready”. If it’s there proceed to a test print…
  • Try a print of the Gift of Good Measure on the sheet of draftboard that they sent with the machine for testing purposes, to see if it’s working again. (Or any small print that has a score, an engrave and a cut.)
  • If it’s still locked up, wait a couple hours and try rebooting everything again. Your internet service provider might be having issues somewhere along the line. (No other way to tell if it’s a service provider issue.)

Give that a try and see if it gets you started again. Let support know the results here.

1 Like

Internet is working perfectly fine! I’ve followed your instructions to the “T”…restarted/rebooted…(again)…and nothing! When I turn on the GF it makes this clicking noise and its the same pattern of sounds/clicks everytime. idk if that has anything to do with the software not making the “Print” button.!I’ve even re-synced the GF til it showed the page go to dashboard and start printing. This is all I see…

Hmmmn…I know the white screen means something but I can’t for the life of me remember what…

Support will be able to tell you when they see the ticket, so just hang tight. Sorry.

1 Like

Thank you for your help though!!! I was really on the verge of giving up like I was way in over my head with wanting to learn and get Glow forge! Thank you! I got hope and found patience now lol

1 Like

Can you try a different browser? What happens if you click the shape tool? Can you make a circle to cut?


I’ve had this once when my glowforge wasn’t connecting to my internet after an outage. Since you have tried to restart and power down etc I’m gonna guess your wireless setup was maybe not done correctly? Do you have the ability to see what is currently on your internet signal to confirm that the glowforge is indeed connected?

The different browser tip was the ONLY thing I did not try! THANK YOU that worked! I forget MACs need to use other browsers at times to cooperate! I have my 1st print…Success! Please delete…problem resolved! Cant believe it was something simple! Thank you Jules and dkgood!!!


So happy for you!! You will have more questions. We will be here to help.

1 Like

Any idea of how to get that gift of good measure back? It’s still not rendering a design. :grimacing:

Open the Gift of Good Measure. Click the three dots in the toolbar of the interface. Select design details from the drop down menu. Click reset design.

Got to thinking about solutions in general. It’s always difficult to give accurate P&S advice. Sometimes it comes across as a shotgun approach of things to try. One of the reasons is we will advise anything remotely logical until the problem goes away. Unfortunately just because an issue resolves itself doesn’t always mean what we advised fixed the issue.

Changing the browser was probably the solution. But we can only be sure if you also re-tried the original browser and found that the problem returned AND, someone else has the same issue and had the same solution. If you are so inclined, let us know. thanks.


@sherie671 I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!