Shop Closed?

Was wondering if there is an issue with the shop. Can get to the shop but when clicking on a material i get We’re sorry but something went wrong (500)…

It’s working for me.

I hit that last night but then I refreshed and everything worked fine.
Currently working fine for me.

Spoke too soon. I got into the shop, but then I decided to check if Glass Acrylic is back and I got the 500 error as well!

But, again, I refreshed and can see the acrylics.

Still no Glass Acrylic. And that’s the real error. :wink:

So as I test further it seems that every material starts off with a 500 error and then if I refresh the error goes away. I do think something is wrong.

1 Like

yea that’s what is happening to me but when i refresh i still can’t get in to the materials…

Whooops, I’m seeing that too. But like you say, refresh fixes it.

Some materials took me 4 or 5 refreshes before they’d appear.
But I found once they do load, if I go back to them they seem fine.

tried refreshing several time for each and still getting the error… I even tried getting out of Chrome and restarting… Oh well i try later hope it works i need some leather and Acrylic…

having the same issue with the catalog but nothing else…

Yeah something is up, I went to ‘Settings’ on the shop page and get 404 errors.

Edit: I am also getting random 500 errors around the shop.

yea something is up with the server. Oh well…

Sadly, the status page is useless:


Shop back to normal…

1 Like

Not here, Cannot get to many things. Keep getting:



@DaveL I reinstalled Chrome and the issue went away…

Ok, So sounds like an issue with their site and cookies possibly. I am not having issues with any other site.

I’m getting the 500 error any time I try to purchase anything from the shop. Tried it on Friday night and then randomly through the weekend. Still not working for me.

You should start your own thread in Problems and Support. There’s only one support ticket created per thread, so you need your own in order to get your issue addressed.

1 Like

Thanks! I’ll try it again and if it still happens I’ll make a new thread.

Thanks for letting us know about this, and sorry for the slow reply. It sounds like the problem is no longer an issue, but if it happens again, please do let us know.