Software still not working

Hi it’s 9:30pm here in the UK and I’m trying to upload new designs and play around with ideas before I cut them tomorrow but I’m having a few issues!

  1. It’s not loading up the “new outline” tool
  2. It’s deleted and as altered some of my saved designs!!
  3. The text tool isn’t working. I’m a premium user so not sure why that is.
  4. The new cut/paste/group thing separates my design all across the screen instead of keeping it the same when I group?!

Please let me know if this issue can be resolved ASAP! Thanks!

There have been issues with the interface, but mostly I read that it was resolved. While waiting for support, I suggest you log out of the Glowforge app, clear your cache and then log back in. If the buggy behavior persists, try a different browser. Hopefully they will get this fixed for you soon.

Hi thanks, I’ve done that a few times, the text tool returned and it’s still not letting me create a new cut outline…

Hello! @juliaheartsu I am so sorry you are running into problems with the web app. I saw the email ticket you submitted and responded to you there. To mitigate any confusion I am going to close this thread and I look forward to hearing back from you via email. Thank you for reaching out!