Solved: Unable to connect to Unifi Access Point

I recently upgraded my home network to use Ubiquiti Unifi gear. Shortly afterwards, I noticed that my Glowforge was unable to connect to the network - which is a problem for a 3D laser printer that relies on cloud computing services!

After a bit of internet sleuthing, I tracked it down to a feature in the 4.0.42 firmware for my access point. Disabling the “Auto-optimize network” feature restored full functionality.

Sharing this post in case others have run into similar issues.


Thank you! As a fellow Unifi customer, I really appreciate this. While I haven’t run into the issue, it’s good to know the solution in case I do.

I haven’t forged in the past few days, and haven’t run the latest Unifi updates, so there’s a chance I may hit this in the near future.

I really appreciate you taking the time to share the information!


I’ll have to check out what version I am at, but I have not noticed any issues as of yet. I run all UniFi AP Pro’s with an EdgeRouter.


@CharlesDarwin Dude, THANK YOU! That was exactly the issue I was having. My problem was that I’m running CKG2 and, my nephew was over and plugged in my CKG1 (to be helpful). It totally messed up my network having two controllers. I started resetting everything until I got to the core switch and saw it. I pulled it, re-setup everything and my Glowforge wouldn’t POST. I have 20 laptops to burn asset tags onto and I was going crazy. This was the fix. THANK YOU!


The OP is actually @CharlesDarwin, not me, but I’m glad to be aware of it as well.

LOL< thanks, screen wasn’t fully scrolled…

Happy to hear that this was useful! That was my intent :slight_smile:

This post made my eye twitch a little, if you are going to run enterprise-grade hardware at home you should come up with a networking strategy/layout before just plugging things into it and clicking checkboxes. One of the biggest features of Unifi, IMHO, is the ability to easily create VLANs and isolate low performance or insecure (IoT) devices from the rest of your network. It may also be beneficial to create a separate SSID that only runs on the 2.4 ghz channel just for these devices. This way certain networking features such as “Auto Optimize Network” won’t try to force them to incompatible bands. On top of all that removing IoT devices from your main VLANs/SSIDs allows you to tune your other networks to your hearts desire without worrying what may break.

p.s. @nlucia if you have a fully configured Unifi setup at home the only thing you should ever be rebooting is at most your cable modem. Unless you’ve upgraded that to better hardware too. Unlike standard consumer-grade hardware that is riddled with bugs and generally has very low hardware specs, Unifi equipment won’t be fixed by a reboot. The only way it breaks it when something is misconfigured, a firmware upgrade goes awry, or rarely when hardware fails. In your case, a new device trying to run the network was added. This is one of the main reasons that server hardware typically runs Linux because things don’t just stop working.


I didn’t read up on what the Auto-optimize setting does but you are right in the above, that is exactly how I have everything setup so explains where I have not had any issues. :smile: VLANs for Guest, IoT, Work Laptop, and home stuff ect.

While true for the AP’s I have to say their EdgeRouter gear seems to have gotten a bit less stable lately and needs a reboot here and there.

I’m glad you resolved it! Thanks for sharing the details about what helped. I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!