Sometime Inkscape makes me want to tear out what little hair I have!

Somehow I get into a selection in Inkscape and can’'t get out of it.

This time it’s text.

When I select the text tool all I get is outline text, like this:

A

How do I convert it to regular solid text?

Well I don’t know if it uploaded or not.

1 Like

Can you go to the fill tool at the bottom of the page a set a fill?

1 Like

No that doesn’t work.

OK so here’s the thing. Your text has a stroke and a fill, the tricky part is that your fill is set to be transparent.

It arrives with a black stroke and black fill, but the fill is transparent. Look on the right in the RGBA field, you’ll see it’s 00000000, which means 00 red 00 Green 00 blue and 00 alpha. The alpha value is the transparency, 0 alpha is totally transparent, FF alpha is totally opaque; 0,0,0 RGB is black.

Changing that to 000000FF will make it totally opaque. Step 1.

And now it is filled opaque black.

It still has a stroke, so let’s turn that off. It’s not that much different in appearance (slightly thinner), but it’s the best way to see how the actual engrave will go.

OK, but now you need to convert that to a shape (presumably you want to engrave it). Path->Object to path:

And now we have a path object instead of a text object, which you can confirm with the node tool.

You’re all set.

5 Likes

Well let me absorb this.
No, in this case I don’t want to engrave but score.
It’s also like the box thing. If I have been working with rounded corner boxes, it’s almost impossible to go back to square cornered boxes.

Ah well the process is the same, just after that last step, turn on a stroke and turn off the fill.

I gave you the “right” way to do it for engraves. If you know the size is right, you can just do the path->object to path step, then turn off the fill, and you’re ready to go. This is a very simple action, once you know how to do it.

If your box comes out with rounded corners just click this icon:

3 Likes

I have had the rounded box issue before. If you round one by pulling the handle down in the node editor, Inkscape uses that as your default. If you make one and change it back (use the node editor and pull the corner back up), Inkscape usually returns to square corners for the next one you create.

3 Likes

OK. I get that you can fill in the white area in the text. When I look at tutorials on text the text does not have a fill and a stroke. How do you start out with that? If I select “gasp” Comic Sans, I don’t want to go into each letter (or sentence) and perform an operation on it.

Generally you select the whole text object and to object to path and you’re all good. That converts it to a group of paths that you can modify to have whatever stroke or fill you want.

I want to start out with solid text.
In this Youtube tutorial there is no selecting the whole text object and to object to path.

Type your text. If it comes out as only outlines press CTRL and whatever color you like. I don’t know if it matters or not but I then press SHIFT and the X (at the left of the color selection bar) to remove the outline.
Help

Pretty sure the CTRL is not needed here.

Clicking a color sets the fill, shift-clicking a color (or the x) will set the stroke.

I don’t know what is going on now. Opening a new copy of Inkscape and typing text I can change the outline color but am unable to set any fill color. CTRL has no effect.

It’s likely still set to alpha 0. I already gave you all the tools you need.

If it’s being very difficult sometimes you can reset the alpha by manually changing the fill paint style to a gradient and then back to solid… but it’s just as easy to change the alpha value in the color.

And no the control is not needed, as I just clarified above.

Yes you are correct it goes automatically to fill when you choose a color.