Stuck after connecting to the GF Wifi in the setup

Dear Community and support,
Thank you in advance for any help you can provide! I got my GF Basic yesterday and it failed the wifi setup after asking me for my home wifi password. When I tried to do the setup again I can get only to the point of connecting to the GF wifi (that exists) and then I’m stuck at the screen “Waiting for you to connect to Glowforge Wi-Fi…”.
I’ve tried on different browser, two laptops, my phone, I unplugged router (in 2.4 GHz, WPA-2) and nothing worked.
The signal strength of the GF wifi is strong and not overcrowded in channel 1.
The support suggested that I connect to the GF wifi and type: to get a log but it doesn’t connect to it.
Trying to get to doesn’t load either on my home wifi nor the GF wifi.
I’ve watched carefully the step by step video and read tens of threads on the wifi setup in this useful community but no luck.

It’s really weird to have a laser cutter that is a device targeted to tinkerers that doesn’t have a hard reset switch and a wired connection. It’s incredibly frustrating to have such a big and expensive and desired device lying on my table and not being able to interact with it…

Thank you very much for reading and trying to help me solve this issue,


It’s unclear in your write-up - when you’re seeing the “Waiting for you to connect” screen are you then going to on the same machine - as in, right then? Cuz that’s the next step.

I know you said you went there, but it seemed to be a different time then the first paragraph…

Fingers crossed it’s that easy!

Thank you for your reply. I wasn’t clear sorry. I tried both (waiting 30 minutes on the “waiting for you to connect” and nothing happens and then I tried on the wifi of the GF (which isn’t supposed to work) and on the home wifi (as someone from the support was thinking that the GF might have finished the wifi process, which I don’t think).
I hope you enjoy your GF at least two fold for me until I manage to get it working :wink: !

Yeah, nothing ever happens on the waiting to connect - it’s just waiting for you to go to the app page :-/ Sad that didn’t work.

I’m gonna see if I can dig up the video someone did that walks you through (better than the official instructions) and see if you can figure anything!

Thanks! I saw the video made by a user but I don’t get past the screen “waiting to connect” even if my laptops or phone (in airplane mode as provided and disconnected first manually from home wifi) is connected to the GF wifi. Thank you for helping!

What’s interesting to me is that there are a few screens in the video that I never saw! Anyway, in case this isn’t the one you saw:

Otherwise, wait on staff. They’ll respond here soon enough!

1 Like

Hi, I am actually having the exact same problem with my GF. Have you had any luck getting it to work?

The support wrote me back and now it’s working! The issue was on their side and I state here the friendly support Vee: " It looks like, when Wi-Fi setup was successful, the machine was not associated as expected with your user account. Thanks for pointing that out. In a rare case like this, we can make that association on our end, and that’s what I’ve done. This small adjustment should take care of the issue for you.

Could you please reboot your Glowforge (do not hold down the button on top), and sign in at one more time? You may need to log out and log back in before you’ll see your Glowforge show up.

Please note, we do not recommend a Factory Reset of your Glowforge at this time. If troubleshooting ever calls for a Factory Reset, we will happily advise you of the steps."

Great, great, great!!! now let’s burn, etch and cut!!! Yourrouhhhhouhhh!!!


I’m so happy we were able to help, @guillaume!

@YRCreations, I’m sorry you ran into trouble as well. We try to keep to one topic per post in the Problems and Support section. Can you create a new post with this question? Or, if you prefer, you can write to us at We’ll be happy to look into it for you.


1 Like