Stuck in calibration (like so many others)


#1

My glowforge is (again) stuck in calibration. This happens about half the time I try to use it. You can imagine how frustrating that is.

Here’s the scenario this time…

  1. Started and worked fine for one cut.
  2. Screen would not refresh.
  3. Restarted GF. Stuck in calibration, still showing last image of bed (from prior to restart)
  4. Shut down GF and restarted everything in the network: router, wifi, and computer
  5. Restarted GF. Stuck in calibration, still showing last image of bed (from prior to restart)
  6. Opened app on iphone. Shows last image of bed (from prior to restart)
  7. Restarted GF. Stuck in calibration, still showing last image of bed (from prior to restart)
  8. Restarted GF and repeated wifi setup to reconnect to network. Smooth. Still stuck in calibration, still showing last image of bed (from prior to restart)
  9. Turned off GF, reset wifi channels.
  10. Restarted GF. Stuck in calibration, still showing last image of bed (from prior to restart)
  11. Restarted GF and repeated wifi setup to reconnect to network. Smooth. Still stuck in calibration, still showing last image of bed (from prior to restart)
  12. Shut down, opened lid, restated. (saw that one on the forum). UI shows the lid is open, but… you guessed it, after I close the lid, it is stuck in calibration, still showing last image of bed (from prior to restart)

That’s how I spent the day “enjoying” my glowforge. The bitterness grows with every restart. Can I get a taste of that [quote=“pip, post:25, topic:27575”]small change on our end [/quote] that you served up to meir? Stuck on calibrating!

And if you are asking yourself, if this only happens half the time, what makes it work the other half? I wish I knew. Usually I get frustrated with the 12-step program outlined above, curse a lot, and go to bed. Next time (could be a day later, could be a month) it will work for a bit and then it all starts anew.


#2

Can you check the WiFi signal strength at your GF using an app on your phone? I would like to see if you have the same issue that someone else had this weekend. Their app showed a signal strength of about -50 dB. As soon as they moved the WiFi source nearer their GF the signal strength jumped to -10dB and the problem went away. I theorize that the GF needs a stronger signal to remain stable than some other devices may.


#3

The unit is 5 feet from my Airport Base Station and I can see it connect with “excellent” signal strength. RSSI is -26 to -50; lower number–stronger signal–is when the bridge routers at my network edge are turned off. Turning off those edge devices has otherwise made no difference and eternal calibration continues unabated.


#4

Is there any bright sunlight hitting your Glowforge? I had an instance where my machine was stuck on calibrating, then I noticed a ray of sunshine right over the lid cam. I’m assuming it messed with its ability to calibrate properly.


#5

Nope… but thanks. I’ve seen this attributed as a problem in the forums, so some of my restarts (among the many) were with the cover covered. (not that there was any glare to guard against)


#6

RSSI is your dB level. That is interesting - your bridge routers are interfering with your signal strength. How many other signals do you have in the area? Could one of them be on the same channel and causing interference?

It may be something else also, but the WiFi and the glare are both some of the first things to check.
Have you cleaned the lens and the top of the laser head also? What about manually positioning the laser head under the camera and then turning the GF on?


#7

Yes I tried cleaning (previously) which had no effect. Did it again, and again no effect.

And the time (previously) that I moved the head, it returned home on restart (upper left) and still no calibration.

However, just now, after doing NOTHING, it finally calibrated on restart. But still the image won’t refresh (via restart, via opening lid (it registers as open), nor via using the Refresh Bed Image button). Which is EXACTLY the problem that kicked off my initial problem today and so the machine remains unusable.


#8

Try a different WiFi channel. Try 1, 6, or 11. If you’re already on one of those, switch to one of the others. You don’t even have to restart your 'forge. Just leave it on, change channels, give it a minute and see what happens.

Good luck!


#9

Even though it is not spelled out in my 12 steps above, I did that a couple of times… around steps 7 and 9, as I recall. It had no effect.


#10

What a pain.
Over a year and a half both machines I have used behaved exactly the same. They calibrate in 90 secconds without fail and connection is always solid, in spite of the inexpensive TP Link router being in another room 40+ feet away.

I’m no network engineer, but connectivity is the main variable we all have to deal with. The machines are identical, so the dynamics of the signal must be responsible for the erratic behavior we see.
I can’t imagine the level of frustration you feel since my machine’s operation seems bulletproof.

Regarding WiFi hardware (before glowforge), I did have a big problem with constant dropped connection when I was gaming using what I thought was a robust (expensive) Motorola combination modem/WiFi router. A friend who is a network engineer told me to get a stand-alone WiFi router (the aforementioned TP Link), and I haven’t had a single drop since (years).

I don’t know what is causing your difficulty, but I know that there are a lot of variables that can affect connectivity. I feel sure based on my own experience that once it is resolved you will love that laser as you thought you would.
Good Luck!


#11

Thank you for the words of commiseration, Print2.

And for those of you following along at home, the GF does work today. But that is not surprising. The issue has never been getting it to work after a day or more being idle. The issue is getting it to work consistently for more than a few cuts.

So, my new workflow is this:

  1. Start up in the morning, get all excited about how cool this thing is as I crank our a cut or two.
  2. Turn it off in frustration when it stops working.
  3. Spend the rest of the day pretending I did not pay thousands of dollars on a piece of equipment that only works intermittently.
  4. The next day, repeat steps 1-3, with a focus on not blowing my top during step 2.

You will note that I have eliminated all those restarts and WiFi investigations from the workflow. Since none of that works and the GF will come back online only when it is damn well good and ready, why bother?)

Viola: it is a laser cutter AND an exercise in mindfulness and stress control. (For the money, I would prefer more cutting and less focus on stress-control, but it might be too late for feature requests.)

See you next time.


#12

What about you room temperature? A cool down stop is usually accompanied by a corresponding message in the UI, but I seem to remember someone saying they didn’t get that message.

That was my poorly communicated message, that I don’t think it’s the machine’s fault. From what you describe, it sounds like connection or temperature that is the root of your frustrations.
At any rate, it will be interesting to hear what support says.


#13

We all fall back to looking at wifi issues when this comes up, because it is the ONE thing that is under our control. But the truth is that while suspecting wifi makes a lot of sense, we really don’t KNOW what the cause of this issue is.

If these problems all come down to wifi, as the company seems to insist, then they need to give us better wifi troubleshooting tools, built in to the app. There is surely some key value for signal strength, or quality, that we need to meet. What are those numbers? And what numbers does an individual Glowforge see? If we knew those two things, rectifying wifi problems would be a lot easier. Instead we have to fool around with wifi scanners on our phones, and doing voodoo like changing channel numbers.

The machine logs everything, the company knows everything, but on this important troubleshooting topic, we are kept in the dark.

I cannot imagine how frustrating this is for the afflicted users, and always worry it will be my turn next.


#14

Nope. Not room temperature. In fact, the one time the GF worked for the longest stretch was when the room was warmest. The orange “cool down” light would come on for 1 second at the end of a cut (just as the fan shut down) and one cut did actually show the “waiting to cool down” message before completing successfully. (Ah, memories… that was a nice day. Got probably 10-12 cuts before it balked on me.)

I’m with GrooveStranger (replied elsewhere)… everyone thinks it is WiFi, but where is the proof? Practically speaking, there is no difference between spending hours tweaking WiFi settings before the machine returns to usefulness and spending hours doing nothing before the machine returns to usefulness.

And if it is wifi, I can only say… WTF? Wifi is not new technology and it works everywhere else on thousands of other devices. Also, if you are that lame at instituting wifi, put in a damn ethernet connection.

The one thing we can all agree on… it will be interesting to hear what support says.

“Not the machine’s fault”…? It works half the time, it doesn’t work half the time. When it does work, it usually stops working. When it doesn’t work, it usually comes back. But clearly it is perfectly fine.


#15

I don’t think that’s the general consensus. Almost all machines work fine. Some machines don’t. Many of those are restored to working order by addressing wifi setups (& it’s often reported by Support as something they’re seeing in the machine logs).

However some machines have other issues - some require replacement and some require some kind of intervention by GF and the machine works.

In the absence of a response by Support or while waiting for their response, folks in the community will pitch in with suggestions that have resolved issues in the past. More often than not the solution is found before Support gets involved.

The community can’t look at the machine logs so they can only recommend solutions within the user’s control. After those are exhausted it’s a matter of waiting for Support. Since most problems are file or wifi related that’s where the comments are going to start.

Once those are exhausted you’re going to need to wait for Support and an examination of your machine logs.


#16

Ok, I understand you’re frustrated. That’s going to be the extent of my attempt to help.


#17

I’m so sorry you ran into trouble. I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.


#18