Stuck in "It got too hot for printing"

I have a glowforge pro and have been cutting a file that takes 3 minutes a few times. The temp is 65, and now my unit is stuck in saying “It got too hot to print.” I waited an hour or so, I also tried rebooting a few times only to get the same yellow button and error message. Any advice anyone? I have a deadline on a project that utilizes the glowforge and I need to keep working!

Check the ribbon connection to the head. A bad connection can present as that.

Thanks for the tip, I checked the connection and it is still not working.

Some things to check for:

  • Check the exhaust to make sure it has not been blocked. (Remove the hose and check the grid behind the exhaust fan. If it’s clogged up, clean it with a vacuum and small brushes.)
  • Take a temperature measurement at the air intake. (Lower right side of machine.) Find out if it is within the operating range for that machine.
  • Turn off the machine when not in use.
  • Open the lid on the machine to let hot air in it dissipate more quickly if the external temperature is lower.

These are the official recommendations:

  • Try printing with no material on the bed (so as not to generate smoke and fumes) and no exhaust hose attached. If this works, then the problem may be that your exhaust hose is constricting the flow of air out of the unit, preventing cooling.
  • Examine the bottom-right side of your Glowforge, and ensure that there is no fabric or other flexible material underneath it, like a tablecloth. There are air intake vents, and if they become obstructed, it makes cooling less effective.
  • Try pointing a fan at the right side of your Glowforge. If there is warm air around the intake, this could help it cool off.
  • Power off your Glowforge when you are not using it. When your Glowforge sits idle, the fans are off, so heat can build up
  • Just wait. Your print may take a little longer when it’s warm, but your Glowforge will protect itself and make sure it cools enough to prevent any loss of power or damage. It’s clever enough to pick up from exactly where it left off, even if it needs to pause to cool down during the print!
  • Ensure that the sun isn’t shining on the lid. This could cause the inside of your Glowforge to heat up.
  • If you are venting outdoors, ensure that extreme temperatures or humidity do not enter the Glowforge unit through the exhaust hose. Disconnect the hose from the outside air when the Glowforge is not in use.
  • Turn your Glowforge off and open the lid for a few minutes before trying again. It’s possible for the air in your Glowforge to heat up, just like a car in the sun on a hot day, opening the lid will help that warm air to escape and your Glowforge to cool down.

If you are still having issues after running through the checklist, let the folks know here and support will look into it further.


I went through this checklist last night and still nothing. I turned the unit off for 12 hours and I am still having the same issue. Right from the get-go of turning it on, the button is yellow and no calibration of normal start-up occurs.

Well, if you’ve also checked the ribbon cables, now you’ll need to wait to hear from support. (That’s about all we can suggest without them looking at your machine logs to see what’s going on.)

Good luck!

1 Like

Thanks Jules!


Some folks at marginal temps have bought room or personal AC units to pump cold air into the intake. There could be another issue causing the problem but apparently the universe limits the range of temperatures that the tubes can operate with a reasonable lifespan, so the sensors are conservative.

The jobs I have been cutting are pretty low (3 to 5 minutes) and the temperature here in LA is an even 65. I also have let the unit cool now for 24 hours and I still get the same error message when I turn the system on. I do not think it is temperature related at all.

Thanks for letting us know about this, and I’m so sorry for the delay in our response. I see you emailed us about this, as well, and I just followed up there with instructions on what to try next. I’m going to close this thread so we can continue troubleshooting there.