Stuck on Cancelling, Now can't connect GF to WIFI. Error Message... :/

Hey all!
Maybe someone can help me…

I’m a founder and I’ve had a few issues over the time we got our Pro unit. But they have gotten solved here in the forums or with support or with (2) replacement machines now…

So we have another problem:

  1. Every time I pull up my dashboard to upload a design to make, I get the error message: “Were sorry, an unexpected error has occurred.” I have always clicked ‘Got It’ button and went on with whatever project I am working on without issue. I figured something was going on with the GF mothership and they would get it worked out eventually and the message would go away. Nope. It’s been there a long while for me.

  1. Today we had a bigger problem:
    I was running some prints and ran into a problem.

First, I was running 16 small prints at one time - 4 rows of 4.
It ran the columns 2-4, but not the first column.
After it ran and finished I deleted columns 2-4 and ran it again to get the first column done. It only ran the first 2 rows of the 1st column. So, I deleted the first two so I could get the last 2 done and the glowforge got hung up. So I cancelled the print.

Now, it’s stuck on cancelling. It won’t do anything else.
I tried a variety of fixes that have worked in the past:

  • Cycled the glowforge power.
  • Cycled the web browser (Chrome).
  • Turned off the glowforge and moved the carriage and print head under the camera and turned it back on.
  • Did the above in a variety of orders.
  • Loaded a new print.

None of it worked, so I tried to re-connect the glowforge to the internet. I got the teal button and was got the PC connected to the glowforge with the network settings and my wifi was not found in the glowforge window. I manually typed it in. That didn’t work. So I tried it all again and it found the wifi. I connected, but got an error message ‘Device Error!’ (see screen shot below). I tried it again and sometimes the glowforge would find my wifi and sometimes it wouldn’t - but every time I got the ‘Device Error’ message.

Of course this happens when I really need this working to fill some large orders.

Please help!

Oh, I have also toggled all of the ribbon clips up and down and made sure the ribbon wires were connected. I took off the print head and cleaned all the glass…

Have you turned off your network and restarted it after letting it sit off for at least 2 minutes? Start from the wall and work toward the GF, allowing each network device to boot completely before starting the next one.


There it is!
Thanks ben1 !

I cycled the router earlier, but didn’t leave it off long enough I guess…


Glad that worked! I find this method to be superior for network resets.


I’m sorry you ran into trouble with your Glowforge printer’s Wi-Fi connection. I’m glad to see that the advice you received got you back up and printing! Thanks @ben1!

I’m going to close this thread. If you run into trouble again, or have any questions, please post a new topic here on the forum or email us at and we’ll be happy to help.