Stuck on Centering (just like all of you)

Looks like I’ve joined the “stuck on centering” group. I don’t know what happened as I was having no problems at all yesterday or earlier this morning. I had cut a piece of draftboard earlier without issue. Now, when I turn on the Glowforge, it goes through it’s normal process until it gets to “Centering” – at that point nothing happens. The arm doesn’t move. The printer head is completely still. It just sits there.

I went through other posts on here looking at different troubleshooting steps. I used a zeiss wipe on the lid camera. I checked the cables and their connections and do not see any issues there. I rebooted my router thinking it might be a connection issue, but that did nothing. I’m at my wits end.

I reached out to support to see if there is anything they can see on their end, but in the mean time, I’m hoping for any potential help from the Glowforge community. This isn’t the first time I’ve had a “stuck on centering” issue, but since this seems to be a new widespread issue, I’m hoping the community might have had luck with a troubleshooting step I’m not thinking of or seeing.

New wrinkle. I left the lid open for about a half hour to see if there was a firmware update getting pushed through that had been interrupted. When I closed the lid, the arm moved to the center under the camera, but it was like it couldn’t find it. It just kept moving past the center and down until it hit the bottom. The top of the Glowforge printer head did have some dust and stuff still on it, so I thought that might be it so I turned t off again. Cleaned the top of the printer head. Then, I wiped the camera lens one more time for good measure. I turned it back on, but we’re stuck back at square one. Stuck at centering and not moving.

The weird part though – I’m getting a bed image. I thought I might be having a camera issue, but the bed image is an accurate one. I had material in there. And now I don’t and it’s updated to show the empty tray in there.

I’m at a loss.

I have noted that sometimes there are issues when the ambient light is too bright on the Glowforge. Like a sunny window.

Not having good error messages that you can debug is a problem here. Is it WiFi. Is it hardware like a bad cable? Is it software? Is it dirt? Hard to tell. Glowforge can look at logs and assist.

You might try manually centering the head under the camera and then turn it on.
There was a similar report today and that fixed it.

Had the pleasure of discovering tech chat option today and they seem to think it’s a cord issue. A bunch of people seem to be having that issue with the recent camera update. So I’m hoping it’s an easy fix! I’m out of warranty and just waiting on an invoice to pay for the needed part. I’m hoping they get that to me soon :slight_smile:


We tried that earlier and no luck. I’m willing to give it another go though. GF thinks it’s a cable issue. A bunch of people seem to be having the same problem. I’m wondering if it’s due to the recent camera update. Just waiting on GF to send me my invoice :slight_smile:


I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.